Transmission issue?
NEWS
 

  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
Like Tree7Likes

Thread: Transmission issue?

  1. #1
    Driver's Ed
    Join Date
    Feb 2013
    Posts
    10

    Transmission issue?

    so i have a 1.8l.. and heres the thing with it..
    it jerks when shifting to 2nd gear on slow acceleration..
    on hard, it sometimes get stuck and engine keeps reving
    changed transmission fluid *not filter*
    and a computer diagnosis says the transmission fulid pressure is high
    first, what could be a possible list of problems?
    2nd how much could they approx. cost?
    3rd, how much could a transmission oil filter cost? apparently car's on 63k km and no one ever got it serviced before *i'm the vehicles 2nd owner* and the transmission oil i changed was a black sticky liquid.. o.0
    Last edited by fahadj2003; 02-25-2013 at 11:03 AM.

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    Retired Moderator

    Join Date
    Aug 2011
    Location
    Rochester, NY
    Posts
    5,087
    It appears you're in Saudi Arabia, so I believe you're not covered under warranty for this one. From what I've heard, American car companies in Saudi offer very short warranties.

    I'd change the transmission fluid again so it's not pitch black and give it 100-200 km to see if it improves. You also might want to consider a transmission fluid cooler, since black transmission fluid means it's cooked.

    What fluid did you put in? Was it compatible with Dexron-VI? I know it might be a pretty penny, but visiting a GM dealer for some genuine AC Delco Dexron-VI instead of some no-name fluid may help.
    fahadj2003 likes this.
    2012 Chevrolet Cruze Eco
    2009 Honda Fit Sport

    Learn from the mistakes of others, so when you err it can be in new and interesting ways.

  4. #3
    Driver's Ed
    Join Date
    Feb 2013
    Posts
    10
    well i didnt personally change it but i am taking the car in for servicing this weekend, gonna ask em to change that
    yup, the warranty was out on 50k, around 14,000 km ago.. ._.
    they're making me pay around 1000$ for opening my transmission *thats just the labor cost*
    kinda made me wonder if black oil means filter clogged and needs replacement or not.. plus, is the filter inside the transmission itself or somewhere external so i can avoid the 1k ._.
    im sure the transmission isn't that bad coz the jerking got reduced alot after the oil change and it's probably the filter at most..
    also, cruze 2010 has the same transmission software updates like 11/12 models? mine is a LS if it matters..

  5. #4
    Retired Moderator

    Join Date
    Aug 2011
    Location
    Rochester, NY
    Posts
    5,087
    Black ATF means change the old ATF out a little bit at a time and see if it gets better. There's no need to remove the transmission to drain the fluid.

    IIRC these transmissions have an internal filter. I would not change the filter yet since it's such a pain to get to. Change the ATF again with Dexron-VI, since changing the ATF once will only get out 50% of the ATF in the transmission. There's still a lot of old, nasty ATF in that transmission.
    fahadj2003 likes this.
    2012 Chevrolet Cruze Eco
    2009 Honda Fit Sport

    Learn from the mistakes of others, so when you err it can be in new and interesting ways.

  6. #5
    Driver's Ed
    Join Date
    Feb 2013
    Posts
    10
    is changing twice going to be enough?
    also, the transmission software updates, are they for all cruzes? or jus specifically 2011/2012 models?
    i've got a '10 LS..
    thing is, i live in a really ignorant country.. even the GM's showroom/service station wont bother with it or answer coz apparently everyone else is a retard and the normal ones are treated the same..
    also, how can i find out current version number?
    Last edited by fahadj2003; 02-26-2013 at 03:00 PM.

  7. #6
    1st Gear
    Join Date
    Jul 2011
    Location
    Toronto, Ontario
    Posts
    329
    My 2011 LS does the same thing, I wish this car had a dip stick for the A/T

    I have even brought that up with the dealer as well "i heard these can sometimes come with too much fluid in the A/T"

    He wasn't able to do anything about it because he couldn't find a work order or whatever you call it.

    These transmissions are supposed to be sealed for life aren't they?

  8. #7
    Retired Moderator

    Join Date
    Aug 2011
    Location
    Rochester, NY
    Posts
    5,087
    If nothing changed internally in the transmission between your 2010 and the 2011/2012, then a newer reflash than what's currently on the transmission computer should work. Unfortunately, the only way to know is to connect up a GM scanner to the car and read the transmission computer.

    I'd change the fluid 3 times in all, or twice more, and call it good. That'll get out ~88% of the old fluid.

    For the last point, "lifetime filled" or "sealed for life" means lifetime of the warranty. Here, that's 5 years/100k miles. If you want your car to last longer, it's advised to change the ATF well before that. Every 40-50k miles should be okay with Dexron-VI, sooner if you're in a warm climate.
    fahadj2003 likes this.
    2012 Chevrolet Cruze Eco
    2009 Honda Fit Sport

    Learn from the mistakes of others, so when you err it can be in new and interesting ways.

  9. #8
    Driver's Ed
    Join Date
    Feb 2013
    Posts
    10
    since im gonna go to a mechanic anyway, is there a way that i can flush the full oil? like 100%? without opening the transmission?
    sorry, im a car noob..

  10. #9
    Retired Moderator

    Join Date
    Aug 2011
    Location
    Rochester, NY
    Posts
    5,087
    In cases like yours where the transmission fluid is black, changing it slowly is better than changing it all at once. Changing the ATF a little at a time, such as draining out 5 quarts, refilling with 5 new quarts, and then repeating a few weeks later until the fluid in the transmission is red, generally works better than changing all the ATF at once. This problem took a while to develop, is likely fluid-related, and needs a while along with several fluid changes to go away. There are no "quick fixes" to a dirty transmission.
    obermd and fahadj2003 like this.
    2012 Chevrolet Cruze Eco
    2009 Honda Fit Sport

    Learn from the mistakes of others, so when you err it can be in new and interesting ways.

  11. #10
    Driver's Ed
    Join Date
    Feb 2013
    Posts
    10
    one last question
    about the shifting
    somehow it shifts to 3rd gear and shifts back to 2nd at full rev and stays there till i let go of the accelerator *which is 3/4 or full down*
    i checked this by switching to manual when revs are full and then back to D.. and its not always reproducible.. more like a 50/50 chance of this happening..
    can someone gimme an idea on what can cause this? TCM? fluids? engine? filter?
    they're charging me 250$ for transmission oil change
    wtf?
    seriously?
    Last edited by fahadj2003; 02-27-2013 at 07:55 AM.

  12. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

Page 1 of 2 12 LastLast

Similar Threads

  1. Cruze Eco Manual Transmission issue/question
    By KenJr in forum General Discussion Forum
    Replies: 28
    Last Post: 08-07-2012, 12:21 PM
  2. Auto Transmission issue
    By cyper2002 in forum Service Issues
    Replies: 10
    Last Post: 06-27-2012, 11:38 PM
  3. 2011 auto cruze lt1 - transmission issue
    By IHATEMYCRUZE in forum Powertrain
    Replies: 5
    Last Post: 06-12-2012, 07:57 AM
  4. Transmission issue gone... (one of them anyway)
    By Jaycruze in forum Service Issues
    Replies: 4
    Last Post: 03-06-2012, 01:36 PM
  5. Transmission Issue
    By cyper2002 in forum Service Issues
    Replies: 5
    Last Post: 12-04-2011, 10:38 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2