So... Water Pump went
NEWS
 

  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Page 1 of 8 123 ... LastLast
Results 1 to 10 of 72
Like Tree9Likes

Thread: So... Water Pump went

  1. #1
    1st Gear VictoryRed08's Avatar
    Join Date
    Feb 2011
    Location
    The Great White North
    Posts
    391

    So... Water Pump went

    So a few weeks ago I got a check engine light along with a message in the Driver Information Centre saying that the "A/C was turned off due to high engine temp", all while driving. Then the message went away along with the CEL.

    Odd, I thought. I went home and went to go drive the car later and I got the same thing except now the engine temperature gauge was jumping up and down & sounded like the fan was running a mile a minute. So I called the dealer and booked an appointment, popped the hood on the car, checked the coolant, it's empty... Filled it with some water & checked all the hoses and there was no apparent leaks.

    Took it to the dealer a few days later and turns out the water pump was leaking. They then replaced it. While they were at it, they reflashed it to fix the HVAC controls which were outputting air incorrectly. Yeeha.

    2011 Chevrolet Cruze 1.4t - 35% tint, K&N Intake & Black Bowties.

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    Retired Moderator shawn672's Avatar
    Join Date
    Oct 2010
    Location
    Rochester, NY - Charlotte, NC
    Posts
    2,475
    Hola! Haven't heard from you in awhile buddy

  4. #3
    1st Gear VictoryRed08's Avatar
    Join Date
    Feb 2011
    Location
    The Great White North
    Posts
    391
    Quote Originally Posted by shawn672 View Post
    Hola! Haven't heard from you in awhile buddy
    Ya, tell me about it. Been working a lot, haven't been on the forum in a month or two, I miss anything? lol

    2011 Chevrolet Cruze 1.4t - 35% tint, K&N Intake & Black Bowties.

  5. #4
    Handbrake Released maven's Avatar
    Join Date
    Feb 2011
    Posts
    187
    I already replace two water pumpees
    Custom built headlight retrofits, wiring harnesses and lighting supplies & parts.

  6. #5
    1st Gear VictoryRed08's Avatar
    Join Date
    Feb 2011
    Location
    The Great White North
    Posts
    391
    Quote Originally Posted by maven View Post
    I already replace two water pumpees
    Oh great, something to look forward to...

    2011 Chevrolet Cruze 1.4t - 35% tint, K&N Intake & Black Bowties.

  7. #6
    Handbrake Released maven's Avatar
    Join Date
    Feb 2011
    Posts
    187
    Nah, **** happens. Ive worked on a lot more that didnt need pumps than did
    Custom built headlight retrofits, wiring harnesses and lighting supplies & parts.

  8. #7
    Handbrake Released
    Join Date
    Jul 2011
    Location
    Florida
    Posts
    119
    Was the pump making any sort of noise before it failed?
    Gone: 2001 Grand Prix GTP blk/blk
    Ordered 11/7, Delivered 12/17: 2012 2LT RS 6mt Blue Topaz/Neutral Leather

  9. #8
    Learning about my Cruze
    Join Date
    Oct 2011
    Location
    Memphis TN
    Posts
    82
    Pumping noises

  10. #9
    5th Gear GoldenCruze's Avatar
    Join Date
    Dec 2011
    Location
    Central Ohio
    Posts
    904
    The temp gauge jumping around is a good indicator of low coolant level. What happens is the fluid starts surging, or percolating past the temperature sensor. One moment it is in contact with the fluid, the next it's not.

  11. #10
    Driver's Ed
    Join Date
    Nov 2012
    Posts
    1
    I have a 2011 Cruze 1LT. It's been towed three (3) times for over heating. First time coolant was low no leaks, 2nd time a hose was leaking, and now it's the water pump. I really love my Cruze, but not all the hassle. Definitely trading it in now.
    fastdriver likes this.

  12. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Similar Threads

  1. Pain at the pump
    By some_goat in forum Off Topic Discussion
    Replies: 44
    Last Post: 03-15-2012, 05:47 PM
  2. Water in trunk
    By audiobahnman in forum Service Issues
    Replies: 5
    Last Post: 10-24-2011, 09:02 PM
  3. Hard Water Spots
    By Speedy McD in forum Appearance, Detailing, & Interior
    Replies: 14
    Last Post: 09-26-2011, 09:37 AM
  4. Gas Prices? What are you paying at the pump?
    By ChevyPower in forum Off Topic Discussion
    Replies: 20
    Last Post: 05-12-2011, 04:47 PM
  5. Pump Shock...
    By Jim Frye in forum Fuel Economy
    Replies: 23
    Last Post: 05-02-2011, 09:21 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2