Antifreeze Smell Thread - Page 64
NEWS
 

  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
Closed Thread
Page 64 of 109 FirstFirst ... 1454626364656674 ... LastLast
Results 631 to 640 of 1081
Like Tree329Likes

Thread: Antifreeze Smell Thread

  1. #631
    Off-Road Champion
    Jim Frye's Avatar
    Join Date
    Mar 2011
    Location
    NW Ohio
    Posts
    2,669
    Quote Originally Posted by Bohdan View Post
    If so on the soft plug then there new old stock will be the same. Do we know where the pumps are made and why for this soft plug.
    We don't know where the water pumps are made. The question has been asked here before. Until someone can look at the box they come in and tell the world, it will likely be a long time before anyone knows. XtremeRevolution has posted that the water pump problem is known to Chevy and they have taken measures to fix the problem. That having been said, there is no notice of that in GM's Techlink, so wait and see. The overflow reservoir venting near the cabin air intake is a completely different goose. I am still convinced it's a tie in between the electronically controlled thermostat and the pressure that builds up in the overflow tank. I'd be delighted if someone could prove me wrong and show the real reason for the smell. "Ooo Ooo that smell. The smell that surrounds you".
    2013 Crystal Black Pearl Civic EX-L Sedan w/Nav: K&N Drop In
    16,000 Mi., Avg. MPG: 33 City; 44 Hiway; 87 E10; ECON On
    24 months old, not a single problem, issue, or recall.

    I went out to find myself. If I return before I get back, have me wait for me.

    I'm not apathetic, I'm just too old to matter anymore.
    45,151 October '14 YTD
    Quick reply to this message Reply  

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #632
    Learning about my Cruze
    Join Date
    Jan 2012
    Posts
    74
    Yes. The new pumps are identical to the old ones. We stock one, ill check the box tomorrow to see where its from.
    Jim Frye likes this.
    Quick reply to this message Reply  

  4. #633
    Learning about my Cruze
    Join Date
    Dec 2012
    Posts
    75
    Well I got told they pressure tested it and found no leaks, coolant level is fine. They claimed there was no bulletin or anything out regarding this issue. I mentioned PI 0740 and he's like "oh well, we'll go ahead and check this one out..... The service adviser claimed his tech was on the phone with GM tech support. I find it sad that we need to tell these guys were to look to fix a potential issue.
    steve333 and jdubb11 like this.
    Quick reply to this message Reply  

  5. #634
    BOOOOST!
    Hoon's Avatar
    Join Date
    Mar 2012
    Posts
    1,279
    I am starting to get the smell intermittently. At times it can come on so suddenly and strongly that it is instantly nauseating. Film on the windshield, and res. level is about 1.5" lower than it was at my last oil change 3K miles ago....either that or i didn't notice that it was already starting to lose coolant.

    Car is 9 months and 14K miles old. Having toxic coolant leaking into the passenger compartment/coming through the vents is not at all OK.

    I'm tempted to try to find it myself, but if i do then i'd still have to bring it into the dealer for the warranty work or i assume i'd have to pay out of pocket for whatever part(s) are needed... and that's not going to happen on a new car.
    steve333 likes this.
    '12 Cruze 1LT M6 - K&N Drop In, Intake Resonator Delete, Black Label Tuned - 162whp/186wtq @ 18.5psi

    '05 GSXR750 - Big ole turbo.
    Quick reply to this message Reply  

  6. #635
    1st Gear
    Join Date
    Dec 2010
    Location
    upstate, NY
    Posts
    255
    Quote Originally Posted by Hoon View Post
    I am starting to get the smell intermittently. At times it can come on so suddenly and strongly that it is instantly nauseating. Film on the windshield, and res. level is about 1.5" lower than it was at my last oil change 3K miles ago....either that or i didn't notice that it was already starting to lose coolant.

    Car is 9 months and 14K miles old. Having toxic coolant leaking into the passenger compartment/coming through the vents is not at all OK.

    I'm tempted to try to find it myself, but if i do then i'd still have to bring it into the dealer for the warranty work or i assume i'd have to pay out of pocket for whatever part(s) are needed... and that's not going to happen on a new car.
    We found it, GM just won t fix it.
    Quick reply to this message Reply  

  7. #636
    BOOOOST!
    Hoon's Avatar
    Join Date
    Mar 2012
    Posts
    1,279
    Quote Originally Posted by cerbomark View Post
    We found it, GM just won t fix it.
    Have the interior issues (smell/film) also been traced backed to the water pump bolts/soft seal?
    '12 Cruze 1LT M6 - K&N Drop In, Intake Resonator Delete, Black Label Tuned - 162whp/186wtq @ 18.5psi

    '05 GSXR750 - Big ole turbo.
    Quick reply to this message Reply  

  8. #637
    1st Gear
    Join Date
    Dec 2010
    Location
    upstate, NY
    Posts
    255
    Quote Originally Posted by Hoon View Post
    Have the interior issues (smell/film) also been traced backed to the water pump bolts/soft seal?
    Not on mine and many I see here. There are no leaks in many if not most of these complaints. Also anyone who has posted a leak as the cause has only seen the smell re appear. I don t think those small leaks are the main issue. A small drip from the bolts on the water pump would not give the consistant strong odor I have. If that s the main cause why do so many have the smell and no leak, IMO, because it s the vent on the tank. They have put the dye in mine too and found nothing leaking.
    Quick reply to this message Reply  

  9. #638
    Learning about my Cruze
    Join Date
    Dec 2012
    Posts
    75
    Dealership called and said they are replacing the heater core... I hope to **** this works! it will be in next week.
    Quick reply to this message Reply  

  10. #639
    1st Gear
    Join Date
    Dec 2010
    Location
    upstate, NY
    Posts
    255
    Quote Originally Posted by blackcruzelt View Post
    Dealership called and said they are replacing the heater core... I hope to **** this works! it will be in next week.
    I thought you said you had no leaks??? Why replace the core?? I don t want to jinx you but sounds like a fishing expedition to me. Someone else post here about a heater core change that did not solve the issue...
    Quick reply to this message Reply  

  11. #640
    BOOOOST!
    Hoon's Avatar
    Join Date
    Mar 2012
    Posts
    1,279
    Quote Originally Posted by cerbomark View Post
    Not on mine and many I see here. There are no leaks in many if not most of these complaints. Also anyone who has posted a leak as the cause has only seen the smell re appear. I don t think those small leaks are the main issue. A small drip from the bolts on the water pump would not give the consistant strong odor I have. If that s the main cause why do so many have the smell and no leak, IMO, because it s the vent on the tank. They have put the dye in mine too and found nothing leaking.
    So then we haven't found it.

    I don't see how the smell could be generated from a slow steady leak. I go days without smelling anything, and then all of a sudden get a smell so strong I have to put the window down in <30* weather or i'll be sick.

    I've had several vehicles with a slow leak from the "weep hole" on the water pump and didn't notice for some time.
    Last edited by Hoon; 01-03-2013 at 02:02 PM.
    '12 Cruze 1LT M6 - K&N Drop In, Intake Resonator Delete, Black Label Tuned - 162whp/186wtq @ 18.5psi

    '05 GSXR750 - Big ole turbo.
    Quick reply to this message Reply  

  12. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Similar Threads

  1. Replies: 67
    Last Post: 05-23-2014, 10:37 AM
  2. Gas smell on restart??
    By pianoman in forum General Discussion Forum
    Replies: 8
    Last Post: 04-23-2014, 11:40 AM
  3. oil smell at Idle
    By rcclockman in forum General Discussion Forum
    Replies: 22
    Last Post: 03-14-2014, 06:41 PM
  4. Antifreeze Smell in Cabin
    By herdiamond in forum Powertrain
    Replies: 51
    Last Post: 01-30-2013, 12:50 AM
  5. Antifreeze Smell
    By Farmer Fran in forum Powertrain
    Replies: 32
    Last Post: 01-15-2013, 10:29 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2