Thermostat
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 42

Thread: Thermostat

  1. #1
    natadog is offline [OP]
    Driver's Ed
    Join Date
    Nov 2010
    Posts
    5

    Thermostat

    I have not paid my first month yet and my Cruze has been in the shop since Tuesday . I called the Service department today and they told me that the part is on back order and it will be a while until it comes in. I have 600 miles on my car, haven't even revved the engine up in it yet and the thermostat is broken... It concerns me that i already have this issue, and it concerns me more that a thermostat will take a while to come in...

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    Retired Moderator shawn672's Avatar
    Join Date
    Oct 2010
    Location
    Rochester, NY - Charlotte, NC
    Posts
    2,475
    Considering the thermostat is driven by the ECU, it could be a lot worse (or they misdiagnosed the car)...

    There are almost no parts available for the car, everything is on back order due to all new parts going into new cars.. sorry about the issue. May we ask what symptoms occured previously to you taking it to the dealer?

  4. #3
    natadog is offline [OP]
    Driver's Ed
    Join Date
    Nov 2010
    Posts
    5
    I hope it isn't worse... what first alarmed me is the temp gauge wouldn't move, it stayed cold after driving it to work, then my Air Condition shut off and a message displayed "AC off Due to High Engine Temp".

  5. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  6. #4
    Retired Moderator shawn672's Avatar
    Join Date
    Oct 2010
    Location
    Rochester, NY - Charlotte, NC
    Posts
    2,475
    that does looke like the thermostat, i just hope it doesnt have anything to do with the ecu, i'm not sure how much it actually controls, other then i know it keeps the engine temp at 220degrees all the time

  7. #5
    natadog is offline [OP]
    Driver's Ed
    Join Date
    Nov 2010
    Posts
    5
    Ya, the service guy told me I could have driven the car, but I would not have heat, I told them I want them to keep it until it's fixed, so they agreed, I just hope it isn't too long, I want my car...

  8. #6
    Retired Moderator shawn672's Avatar
    Join Date
    Oct 2010
    Location
    Rochester, NY - Charlotte, NC
    Posts
    2,475
    love that color man, so jealous

    i hope they gave you a loaner at least? i cant believe they'd let you drive it with a broken thermostat, i'm pretty sure that could cause engine failure if the fans are not turning on and it overheats..

  9. #7
    natadog is offline [OP]
    Driver's Ed
    Join Date
    Nov 2010
    Posts
    5
    They gave me a Silverado Quad Cab, so ya I appreciate that, but I still miss my car.

  10. #8
    Handbrake Released
    Join Date
    Nov 2010
    Posts
    193
    That check engine light is not good. But it seems you have it figured out. If it is the ECU, the thing about electrical parts is that they typically will go very quickly if they go. So now it will be fixed and you will be good to go.

  11. #9
    Handbrake Released
    Join Date
    Nov 2010
    Posts
    157
    suck this had to happen when you just got it, i wonder what would cause the thermostat to fail so quickly on such a new car

  12. #10
    Driver's Ed
    Join Date
    Nov 2010
    Posts
    7
    Most faulty parts will fail with in the first few KM. It happens be thankful the DIC caught it so fast and actually did something to protect the engine. Older cars would have just burned the engine out.

    I always run my cars in easy for the first bit until after the dealer recommended break in.

    Then I push the engine hard for a few weeks just to see if there are any week parts.

    After that I go back to driving my normal.

    I also had a heating issue in a 1994 Z24 during break in. The radiator turned out to be bad. It had a restriction somewhere inside. That car also had an issue with the DRL but all was fixed and it never had a problem again.

  13. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread
Page 1 of 5 1 2 3 ... LastLast

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. Thermostat temperature
    By oldman2 in forum Gen1 Powertrain
    Replies: 4
    Last Post: 12-06-2011, 08:41 AM
  2. Does the 1.8 have a computer controlled thermostat?
    By Dale_K in forum Gen1 Powertrain
    Replies: 6
    Last Post: 10-05-2011, 04:53 PM
  3. Bad Thermostat at 1,645 miles
    By pbeyer2010 in forum Gen1 Service Issues
    Replies: 12
    Last Post: 09-09-2011, 12:03 AM
  4. #10399A Service Update Thermostat Sticks In Open Position.
    By ChevyMgr in forum Gen1 Service Issues
    Replies: 0
    Last Post: 11-30-2010, 06:00 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2