View Profile: eddiefromcali - Chevy Cruze Forum : Chevrolet Cruze Forums
About eddiefromcali

Basic Information

Statistics


Total Posts
Total Posts
398
Posts Per Day
0.62
General Information
Last Activity
Today 12:38 AM
Join Date
08-21-2017
Referrals
0

02-15-2019


01-31-2019


08-16-2018


08-15-2018


Page 1 of 11 1 2 3 ... LastLast

05-20-2019


05-15-2019


05-03-2019


05-02-2019


05-01-2019


04-30-2019


04-25-2019


04-18-2019


04-15-2019


04-11-2019



Page 1 of 11 1 2 3 ... LastLast

72 Likes

Page 1 of 5 1 2 3 ... LastLast
  1. Blasirl
    Blasirl liked post by eddiefromcali On thread : Boost only at 4 psi Max.... Sometimes.....
    LTFT looks like youre running lean but vacuum looks good so I wouldn't suspect a leak at idle at least. Was that in P or D? Can you get a "commanded boost" and "actual boost" PID and take a...
    Liked On: 05-04-2019, 06:16 PM
  2. Blasirl
    Blasirl liked post by eddiefromcali On thread : Eddie's 2014 Cruze slow build
    slapped some 52lb injectors on the car and ordered a GTX250
    Liked On: 04-29-2019, 05:13 PM
  3. plano-doug
    plano-doug liked post by eddiefromcali On thread : Ignition coil connector
    Broke the clip on mine a year ago, I just put it back on and its been fine since. I think the plug is available online, $80ish or so for one I found when I was looking.
    Liked On: 04-25-2019, 11:13 AM
  4. Greg@IDParts
    [email protected] liked post by eddiefromcali On thread : HowTo: Install a front upper Ultra Racing strut bar
    my passenger side is harder to move than the driver side. Little play but it still moves some.
    Liked On: 04-25-2019, 10:46 AM
  5. Ravenkeeper
    Ravenkeeper liked post by eddiefromcali On thread : The dreaded P0171, any chance powertrain will cover any of it?
    Don't accept the car without verifying that the valve is there and at least looks clean.
    Liked On: 04-22-2019, 06:04 PM
  6. Blasirl
    Blasirl liked post by eddiefromcali On thread : LED Turn Signal Hyper Flash
    how and where did you install the load resistor? post pics I run their switchback led and resistors, not a single problem
    Liked On: 04-12-2019, 06:34 AM
  7. Knapman
    Knapman liked post by eddiefromcali On thread : BNR GTX14 Turbocharger Upgrade
    the gtx14 has been discontinued....a bigger turbo should be out in the near future.
    Liked On: 04-11-2019, 01:44 PM
  8. .Cody
    .Cody liked post by eddiefromcali On thread : LED Turn Signal Hyper Flash
    If you used the quick splice things, maybe the metal isn't all the way down or didn't cut the wire insulation. I didn't use the splice things, I soldered it all together, not a fan of those things
    Liked On: 04-11-2019, 12:43 PM
  9. Knapman
    Knapman liked post by eddiefromcali On thread : Found a leak!! Boost leak!!!
    that "burnt" look is just oil that's caked on there. Try tightening down on the oem hose clamp at the tb/charge pipe. New tb gasket and properly torqued down should get rid of that leak. Fix that and...
    Liked On: 04-05-2019, 06:04 PM
  10. Thebigzeus
    Thebigzeus liked post by eddiefromcali On thread : Found a leak!! Boost leak!!!
    that "burnt" look is just oil that's caked on there. Try tightening down on the oem hose clamp at the tb/charge pipe. New tb gasket and properly torqued down should get rid of that leak. Fix that and...
    Liked On: 04-05-2019, 10:45 AM
  11. plano-doug
    plano-doug liked post by eddiefromcali On thread : Battery/ Alt Help (sound system)
    its your amp being picky then. Ask MA what the input range is on their amps....I've never had any amp go into protect at that "low" voltage. Its not uncommon for modern cars go from 11-15v
    Liked On: 02-26-2019, 10:55 AM
  12. clemson27
    clemson27 liked post by eddiefromcali On thread : Battery/ Alt Help (sound system)
    My 05 Silverado has that ground sensor thing on the main batt. I just connected both D3400s together...pos to pos, neg to neg. I upgraded the oem ground through the loop sensor and left everything...
    Liked On: 02-21-2019, 12:22 AM
  13. jblackburn
    jblackburn liked post by eddiefromcali On thread : The never-ending vacuum/boost/turbo saga. BONUS: BNR, PCV Fix, & Intake!
    Spark plug gap would be my guess for that sputtering
    Liked On: 02-15-2019, 10:19 PM
  14. dw4pres
    dw4pres liked post by eddiefromcali On thread : Advice
    needs a new turbo oil feed line...cheap and simple
    Liked On: 01-07-2019, 03:30 PM
  15. guuyuk
    guuyuk liked post by eddiefromcali On thread : What did you do to your Cruze today?
    Ported manifold and installed pcv kit. Slapped a ported throttle body on there too...hopefully it wakes it up a bit. Waiting on new gaskets to install it all....
    Liked On: 12-06-2018, 06:29 PM
Page 1 of 5 1 2 3 ... LastLast