Sound from valve cover area
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Results 1 to 5 of 5

Thread: Sound from valve cover area

  1. #1
    Knapman is offline [OP]
    Learning about my Cruze
    Join Date
    Jul 2018
    Location
    Ontario, Canada
    Posts
    89
    I've check my PCV system no change in idle when i cover the diaphragm and then orange "arrow" is there and the hose blows air freely when it when you blow and completely stops when I try to pull air threw it. It does look super greasy in there us this normal?

    So it sounds like a constant clicking almost when I use a long screw driver and hold it to my ear and the other end against the valve cover I hear almost like a constant rubbing and sound kinds changes closer to the timing end of the valve cover, any ideas? Thanks.


    Attached Images Attached Images
    Last edited by Knapman; 12-15-2018 at 12:57 PM.

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    World Rally Champion Eddy Cruze's Avatar
    Join Date
    Jan 2014
    Posts
    4,397
    That clanging clicking noise? I don't hear it

  4. #3
    Knapman is offline [OP]
    Learning about my Cruze
    Join Date
    Jul 2018
    Location
    Ontario, Canada
    Posts
    89
    Quote Originally Posted by Eddy Cruze View Post
    That clanging clicking noise? I don't hear it<img src="https://www.cruzetalk.com/forum/images/smilies/xmas.gif" border="0" alt="" title="Xmas" class="inlineimg" />
    Lol I'm catching a little sarcasm here? I'm a newbie when it comes to cars.. so this is all a learning experience for me.. do you have any helpful advice?

    I'm leaning towards maybe a boost leak and/or possible failure with the evap purge valve. I'm unable to scan for codes at this time though. I was driving today and notice when I was going up a slight hill I had my foot on the throttle steadily and the rpms were jumping up and down within a few hundred rpms of esescesesch other and I could hear the difference in the way the car was revving up and down while I was still steady on the throttle. Also noticed when I stop the car and park the idle drops really low and the car sounds like it is going to die but it fixes itself right away. Any ideas?

  5. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  6. #4
    World Rally Champion Eddy Cruze's Avatar
    Join Date
    Jan 2014
    Posts
    4,397
    My CRUZE Engine sounds like a typewriter which is normal if you can believe it. I couldn't tell from your Video about the other problems but again I do believe you!

  7. #5
    Knapman is offline [OP]
    Learning about my Cruze
    Join Date
    Jul 2018
    Location
    Ontario, Canada
    Posts
    89
    Quote Originally Posted by Eddy Cruze View Post
    My CRUZE Engine sounds like a typewriter which is normal if you can believe it. I couldn't tell from your Video about the other problems but again I do believe you!
    Okay haha thanks and yeah I'm waiting until Friday to pick up a odb2 scanner and gonna try new plugs and running 91 octane I've had to run a threw tanks of 87 threw it recently.

  8. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. "sleigh bell" sound from gear lever area (automatic)
    By jsnowbordr47 in forum Gen2 Appearance, Body, Detailing, & Interior
    Replies: 6
    Last Post: 12-24-2017, 04:14 AM
  2. Valve cover leak :D
    By pntballer925 in forum Gen1 1.8L
    Replies: 32
    Last Post: 10-27-2015, 04:07 PM
  3. Liquid sloshing sound in back area
    By Royalwapiti in forum General Discussion
    Replies: 10
    Last Post: 04-11-2015, 10:09 AM
  4. Valve Cover
    By Jbet in forum Gen1 Service Issues
    Replies: 16
    Last Post: 10-09-2014, 06:56 PM
  5. foglight area cover
    By MjC in forum Gen1 Appearance, Body, Detailing, & Interior
    Replies: 6
    Last Post: 03-14-2013, 09:27 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2