Check engine light/ monitors incomplete
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By panos7

Thread: Check engine light/ monitors incomplete

  1. #1
    Adnilre1 is offline [OP]
    Driver's Ed
    Join Date
    Apr 2019
    Posts
    1

    Check engine light/ monitors incomplete

    Check engine light on. Code p01101(MAF) cHECK ENGINE LIGHT RESETS ON ITS OWN ONCE IN A WHILE. Replaced MAF sensor and air filter. Cleared code with code reader. Same problem. PCV checks ok and can't find any vacuum leaks using carb cleaner. Engine runs fine but after a few drive cycles after resetting code, I'm still getting 2 incompletes on the monitors. Oxygen sensor heater and evap system. Purge solenoid is good and gas level is half tank. wiring connector on MAF sensor also appears to be okay. Any ideas what is causing code intermitantly and incomplete sensors?
    Last edited by Adnilre1; 04-22-2019 at 07:40 PM. Reason: added info

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    Drag Racing Champion
    Join Date
    Nov 2017
    Posts
    1,666
    YOu'll probably have to wait for the code to reappear. The monitors won't complete if there's codes.

    Course, you may not have reached the reset procedure either or there could be other issues.

    Used to be 60 miles driving was required to reset. Not sure what it is these days.

  4. #3
    Handbrake Released
    Join Date
    Sep 2017
    Location
    Antelope Valley, CA
    Posts
    105
    Quote Originally Posted by snowwy66 View Post
    YOu'll probably have to wait for the code to reappear. The monitors won't complete if there's codes.

    Course, you may not have reached the reset procedure either or there could be other issues.

    Used to be 60 miles driving was required to reset. Not sure what it is these days.
    Daughter drove about 60 - (probably closer to) 80 miles yesterday, after we replaced the valve cover on our ECO, before she noticed the CEL turned itself off.
    Chris

    2014 Cruze Eco - Limo-tint (back doors, rear window, & top of windshield), blacked out bowties

  5. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  6. #4
    Driver's Ed
    Join Date
    May 2014
    Location
    Nuremberg, Germany
    Posts
    29
    Do you have a cold air intake?
    If yes, than you need to have an air straghtener before the maf, otherwise many aftermarket air intakes will cause P1101 to appear and make your MAF have crazy readings.If you dont than most probably you have a leak somewhere in the intake tract....check all the plumbinmg and the pcv system to rule those out.
    How are your fuel trims? They're a good indication...
    Blasirl likes this.

  7. #5
    Formula One Champion
    Blasirl's Avatar
    Join Date
    Mar 2015
    Location
    Wisconsin
    Posts
    5,432
    Quote Originally Posted by Adnilre1 View Post
    Check engine light on. Code p01101(MAF) cHECK ENGINE LIGHT RESETS ON ITS OWN ONCE IN A WHILE. Replaced MAF sensor and air filter. Cleared code with code reader. Same problem. PCV checks ok and can't find any vacuum leaks using carb cleaner. Engine runs fine but after a few drive cycles after resetting code, I'm still getting 2 incompletes on the monitors. Oxygen sensor heater and evap system. Purge solenoid is good and gas level is half tank. wiring connector on MAF sensor also appears to be okay. Any ideas what is causing code intermitantly and incomplete sensors?
    Welcome Aboard!

    Don't forget to introduce yourself and your Cruze here.
    Hidden Content "Don't just drive CRUZE!" ༼∵༽ ༼⍨༽ ༼⍢༽ ༼⍤༽

    Hidden Content

    Hidden Content (Hidden Content , Tinted Windows, Husky Floor Liners, shark fin, integral dash cam,Hidden Content , splash guards, Z-Spec Grille, Fogs, Depo smoked turn signals w/amber Diode Dynamics LEDs, Hidden Content UR Rear upper Strut Bar, UR Front Upper Strut Bar) MOTM JAN17 AUG17 AUG18

  8. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. Replies: 4
    Last Post: 08-10-2017, 05:40 PM
  2. Replies: 10
    Last Post: 03-23-2017, 11:43 PM
  3. Check engine light on, TCS/Stabili track light
    By Dandersen110 in forum Gen1 Service Issues
    Replies: 6
    Last Post: 08-21-2015, 11:02 AM
  4. Replies: 6
    Last Post: 10-26-2013, 02:43 PM
  5. Check engine light and "airbag service" light after sub install
    By Bammeh in forum Gen1 Audio & Electronics
    Replies: 25
    Last Post: 05-04-2012, 02:24 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2