Valve cover air leak AGAIN - Page 5
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 42 of 42
Like Tree5Likes

Thread: Valve cover air leak AGAIN

  1. #41
    Driver's Ed
    Join Date
    May 2019
    Posts
    1
    My 2014 Chevrolet Cruze had a cracked valve/cam cover at 60K miles. Just got it fixed at the dealer. They replaced the PCV Check Valve and crank seal.

    Symptoms:
    Loud squeaking from serpentine belt area (I actually thought it was a loose pulley)
    Squeaking went away when away when accelerating, but increased when braking and idling
    Rough idling at stoplights
    Check Engine light went on along with "Service Traction Control" and "Service StabilTrak"
    5-8% reduced fuel economy
    One day the fan did not turn off for a full 2 minutes after turning engine off (in 50 degree weather)

    Cost me $500 to get fixed at the dealer (3 hours x $124 + $105 parts + $25 shop charge) as I was outside the 5 year powertrain warranty. Dealer said this is an issue with many Cruzes and to save my receipt in case GM issues a recall.

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #42
    Formula One Champion
    Blasirl's Avatar
    Join Date
    Mar 2015
    Location
    Wisconsin
    Posts
    5,481
    Quote Originally Posted by Kevin6:33 View Post
    My 2014 Chevrolet Cruze had a cracked valve/cam cover at 60K miles. Just got it fixed at the dealer. They replaced the PCV Check Valve and crank seal.

    Symptoms:
    Loud squeaking from serpentine belt area (I actually thought it was a loose pulley)
    Squeaking went away when away when accelerating, but increased when braking and idling
    Rough idling at stoplights
    Check Engine light went on along with "Service Traction Control" and "Service StabilTrak"
    5-8% reduced fuel economy
    One day the fan did not turn off for a full 2 minutes after turning engine off (in 50 degree weather)

    Cost me $500 to get fixed at the dealer (3 hours x $124 + $105 parts + $25 shop charge) as I was outside the 5 year powertrain warranty. Dealer said this is an issue with many Cruzes and to save my receipt in case GM issues a recall.

    Welcome Aboard!

    Things to look at and keep in the back of your head for now:

    Special Coverage #14311: Negative Battery Cable

    2011-2016 Cruze 1.4 PCV Valve Cover/Intake Manifold Issues

    New Thermostat Failing or Sensor or Other?

    Hidden Content "Don't just drive CRUZE!" ༼∵༽ ༼⍨༽ ༼⍢༽ ༼⍤༽

    Hidden Content

    Hidden Content (Hidden Content , Tinted Windows, Husky Floor Liners, shark fin, integral dash cam,Hidden Content , splash guards, Z-Spec Grille, Fogs, Depo smoked turn signals w/amber Diode Dynamics LEDs, Hidden Content UR Rear upper Strut Bar, UR Front Upper Strut Bar) MOTM JAN17 AUG17 AUG18

  4. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread
Page 5 of 5 FirstFirst ... 3 4 5

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. More PCV and valve cover goodness
    By titan2782 in forum Gen1 1.4L Turbo
    Replies: 26
    Last Post: 10-23-2016, 10:08 PM
  2. Valve cover leak :D
    By pntballer925 in forum Gen1 1.8L
    Replies: 32
    Last Post: 10-27-2015, 04:07 PM
  3. Cruze valve cover gasket replaced
    By kylevh21 in forum Gen1 Service Issues
    Replies: 7
    Last Post: 11-17-2014, 02:15 PM
  4. Valve Cover
    By Jbet in forum Gen1 Service Issues
    Replies: 16
    Last Post: 10-09-2014, 06:56 PM
  5. Removing the valve cover
    By titan2782 in forum Gen1 1.4L Turbo
    Replies: 7
    Last Post: 09-18-2013, 12:34 PM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2