Halp
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
Like Tree1Likes

Thread: Halp

  1. #1
    Scrubbydo1 is online now [OP]
    Learning about my Cruze
    Join Date
    Apr 2019
    Location
    Hennepin County, MN
    Posts
    78

    Halp

    All you mechanics out there, I have a weird problem and can’t seem to get it figured out. 2017 Cruze lt rs Hatch gas, trifecta elite tune and tweaked with two datalog adventures. I’ll start driving, and after one or two pulls the ecu will cut power at 2800 RPM. Boost doesn’t drop at all (have a boost gauge). I have no boost leaks, new spark plugs gapped .025, new air filter, no cat or muffler clogs, turbo is clean and solid, intake is clean and solid, no vacuum leaks. Maybe once a week my knock sensor will randomly trip during a highway merging type acceleration and half of those times will engage limp mode. Have had car to dealer twice with knock sensor replaced and it is claimed that is not the issue. Have been banging my head against the wall trying to figure this out. Any ideas would be greatly helpful. The car will accelerate greatly until 2800 and the computer cuts power to maybe 20%, but , again, boost doesn’t drop. So confused, please help


    Sent from my iPhone using Tapatalk

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    World Rally Champion Eddy Cruze's Avatar
    Join Date
    Jan 2014
    Posts
    4,344
    You have a modified tuned Cruze and the Dealer is doing Warranty work or do you pay?

  4. #3
    Scrubbydo1 is online now [OP]
    Learning about my Cruze
    Join Date
    Apr 2019
    Location
    Hennepin County, MN
    Posts
    78
    I flash it back to stock before bringing to dealer, they have yet to notice


    Sent from my iPhone using Tapatalk

  5. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  6. #4
    Learning about my Cruze
    Join Date
    Oct 2017
    Posts
    86
    What gear are you doing your pulls in? Does it only happen in in 1/2 or in 3/4 as well?

    What gas are you putting in this? Tier 1 gas station or blow Joe's Xtreme fuel gas stop? What octane?

    Sent from my SM-G935W8 using Tapatalk

  7. #5
    Scrubbydo1 is online now [OP]
    Learning about my Cruze
    Join Date
    Apr 2019
    Location
    Hennepin County, MN
    Posts
    78
    It’s when doing merge acceleration in third gear, using BP 93 octane


    Sent from my iPhone using Tapatalk

  8. #6
    Learning about my Cruze
    Join Date
    Oct 2017
    Posts
    86
    Huh, that is weird. I'm going to guess that it doesn't happen when stock? That the tune is for 91?

    Sent from my SM-G935W8 using Tapatalk

  9. #7
    Scrubbydo1 is online now [OP]
    Learning about my Cruze
    Join Date
    Apr 2019
    Location
    Hennepin County, MN
    Posts
    78
    Tune is for 93 and doesn’t happen at stock


    Sent from my iPhone using Tapatalk

  10. #8
    Touring Champion
    MP81's Avatar
    Join Date
    Jul 2015
    Location
    Washington Township, MI
    Posts
    3,590
    Have you done any data logging and sent that back over to Trifecta to see what is going on?
    2014 Chevy Cruze Diesel - MSR 013 17" wheels, Black Bowties, UR Rear Lower Bar
    Hidden Content
    2007 Chevy Cobalt LT Coupe - M62 w/ 2.9" pulley, Header/Downpipe/Exhaust, FE5 Struts/Shocks/Control Arms/Front Swaybar, SSC Springs, Powell Hardcore Rear Swaybar, MSR 045 18" wheels w/ Direzza ZIIs, G85 Recaros + much more
    Hidden Content
    2017 Chevy Volt LT - Black Bowties
    Hidden Content
    1981 Chevy Camaro Z28 - Zapco Amp & Pre-Amp/Equilizer, Kenwood Tape Deck, Pyle 8" Woofers & SEAS 4.5" Mids in Deck, JVC Ribbon Tweeters in Doors, Ceramic Coated Longtubes, 2.5" Pypes Stainless Exhaust, Bilstein B6 Shocks, GW U/L Control Arms, Hotchkis Springs & Sway Bars, DD HDX Cluster
    Hidden Content

  11. #9
    Scrubbydo1 is online now [OP]
    Learning about my Cruze
    Join Date
    Apr 2019
    Location
    Hennepin County, MN
    Posts
    78
    Yes, they had me datalog it tuned and stock, and sent me a new tune. It didn’t have an issue for a few days, and now is back. Data logged again after it started happening again and sent that to them, will get some response once they’re open tomorrow. Wanted to ask on here, and also asked on Cruze performance group on Facebook, maybe someone else had some idea


    Sent from my iPhone using Tapatalk

  12. #10
    Learning about my Cruze
    Join Date
    Oct 2017
    Posts
    86
    Did this start after you put in the spark plugs?

    Throwing any codes?

    Sent from my SM-G935W8 using Tapatalk

  13. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. n00b needs halp!
    By cdb09007 in forum Gen1 Appearance, Body, Detailing, & Interior
    Replies: 6
    Last Post: 08-23-2013, 09:19 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2