CEL and OBD2 codes that appeared today
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
Like Tree4Likes

Thread: CEL and OBD2 codes that appeared today

  1. #1
    1st Gear
    Join Date
    Apr 2018
    Location
    Illinois
    Posts
    357

    CEL and OBD2 codes that appeared today

    CEL came on today with the following codes:

    P0403: EGR flow malfunction
    P0406: EGR flow sensor A high input
    P24A5: (definition unfound), Google search reveals this to be EGR cooler bypass bank 1 control stuck

    Any expert opinions of what is happening here?

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    4th Gear TDCruze's Avatar
    Join Date
    Sep 2014
    Location
    Saskatchewan Eh!
    Posts
    821
    Quote Originally Posted by Barry Allen View Post
    CEL came on today with the following codes:

    P0403: EGR flow malfunction
    P0406: EGR flow sensor A high input
    P24A5: (definition unfound), Google search reveals this to be EGR cooler bypass bank 1 control stuck

    Any expert opinions of what is happening here?
    Could this be directly or indirectly related to your unplugging of the EGR Valve you discussed in another thread?
    Did you ever delete the codes after you plugged it back in?
    2018 Cruze Turbo Diesel 1.6L 9T50 LT
    2014 Cruze Turbo Diesel 2.0L AF40-6
    (Sold) 38.2MPG DIC Lifetime Average

    Hidden Content

    Hidden Content

  4. #3
    1st Gear
    Join Date
    Apr 2018
    Location
    Illinois
    Posts
    357
    Quote Originally Posted by TDCruze View Post
    Could this be directly or indirectly related to your unplugging of the EGR Valve you discussed in another thread?
    Did you ever delete the codes after you plugged it back in?
    I have no idea. When I unplugged the EGR it was a few weeks ago and I immediately plugged it back in when I saw it was going to be a "hard" code that would eventually limit the speed of the vehicle. After enough restarts the CEL went away on its own.

    Yesterday was the CEL showing up for nothing that I actively did, and those are the codes I pulled and then reset.

  5. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  6. #4
    4th Gear TDCruze's Avatar
    Join Date
    Sep 2014
    Location
    Saskatchewan Eh!
    Posts
    821
    Was the engine turned off when you unplugged the EGR?
    Did the codes come back since clearing them the other day?
    2018 Cruze Turbo Diesel 1.6L 9T50 LT
    2014 Cruze Turbo Diesel 2.0L AF40-6
    (Sold) 38.2MPG DIC Lifetime Average

    Hidden Content

    Hidden Content

  7. #5
    4th Gear
    Join Date
    Oct 2018
    Posts
    765
    I'm not sure I caught whether the light has come on again or not?

    Did you CLEAR the DTCs last time you scanned it and these are new?

    Or did the the CEL just go off and you never scanned it?

    DTCs can stay stored long after the light extinguishes. This is normal

  8. #6
    1st Gear
    Join Date
    Apr 2018
    Location
    Illinois
    Posts
    357
    Quote Originally Posted by TDCruze View Post
    Was the engine turned off when you unplugged the EGR?
    Yes. I unplugged the EGR on a cold engine and immediately when starting it threw a CEL and a warning message about "service emissions system" and gave me the start of a 75 mile countdown until speed limiting. I turned the car off, plugged the EGR back in, and started it again. The CEL stayed on for a few more starts and then went away on its own.

    Did the codes come back since clearing them the other day?
    The CEL has not illuminated today. I don't know about codes as I don't have a code reader at home.

  9. #7
    1st Gear
    Join Date
    Apr 2018
    Location
    Illinois
    Posts
    357
    Quote Originally Posted by Ma v e n View Post
    Did you CLEAR the DTCs last time you scanned it and these are new?
    I never scanned or cleared anything when I did the EGR disconnect experiment. I was just driving home from visiting a winery and the CEL came on. Checking the codes then gave me the three listed above (four, actually; the last two were duplicates).

  10. #8
    4th Gear TDCruze's Avatar
    Join Date
    Sep 2014
    Location
    Saskatchewan Eh!
    Posts
    821
    Quote Originally Posted by Barry Allen View Post
    Yes. I unplugged the EGR on a cold engine and immediately when starting it threw a CEL and a warning message about "service emissions system" and gave me the start of a 75 mile countdown until speed limiting. I turned the car off, plugged the EGR back in, and started it again. The CEL stayed on for a few more starts and then went away on its own.

    The CEL has not illuminated today. I don't know about codes as I don't have a code reader at home.
    If it's off now I guess let it be since you don't have a scan tool to check or clear codes.

    If it comes back try and get a hold of a tool that can clear the codes.

    If they come back after that it may be a trip to the dealer.
    2018 Cruze Turbo Diesel 1.6L 9T50 LT
    2014 Cruze Turbo Diesel 2.0L AF40-6
    (Sold) 38.2MPG DIC Lifetime Average

    Hidden Content

    Hidden Content

  11. #9
    1st Gear
    Join Date
    Apr 2018
    Location
    Illinois
    Posts
    357
    Quote Originally Posted by TDCruze View Post
    If it's off now I guess let it be since you don't have a scan tool to check or clear codes.

    If it comes back try and get a hold of a tool that can clear the codes.
    To be clear: When the CEL came on yesterday I did use a scan tool to pull the codes and to clear them. That's how I posted the codes at the top of the thread.

  12. #10
    4th Gear TDCruze's Avatar
    Join Date
    Sep 2014
    Location
    Saskatchewan Eh!
    Posts
    821
    Quote Originally Posted by Barry Allen View Post
    To be clear: When the CEL came on yesterday I did use a scan tool to pull the codes and to clear them. That's how I posted the codes at the top of the thread.
    I wouldn't worry then unless they come back, then take it to the dealer if still under warranty.
    2018 Cruze Turbo Diesel 1.6L 9T50 LT
    2014 Cruze Turbo Diesel 2.0L AF40-6
    (Sold) 38.2MPG DIC Lifetime Average

    Hidden Content

    Hidden Content

  13. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread
Page 1 of 3 1 2 3 LastLast

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. Replies: 6
    Last Post: 02-13-2019, 11:50 AM
  2. Error Codes and CEL
    By Mittenman1 in forum Gen1 1.4L Turbo
    Replies: 2
    Last Post: 10-28-2018, 08:58 PM
  3. P0299 just appeared
    By HiBoost in forum Gen1 1.4L Turbo
    Replies: 6
    Last Post: 08-05-2018, 09:15 PM
  4. Check Engline Light - OBD2 Codes
    By truthstar in forum Gen1 Diesel Technical Discussion
    Replies: 7
    Last Post: 01-12-2016, 02:22 PM
  5. 8 codes for cel and occ. traction control
    By SKULL in forum Gen1 Service Issues
    Replies: 3
    Last Post: 02-25-2015, 09:10 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2