2014 - a/c turned off due to high engine temp
  1. Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums – General discussion forum for Chevy Cruze

    Welcome to Chevy Cruze Forum : Chevrolet Cruze Forums - a website dedicated to all things Chevy Cruze.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Chevy Cruze Forum : Chevrolet Cruze Forums today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: 2014 - a/c turned off due to high engine temp

  1. #1
    Ralphalyn is offline [OP]
    Driver's Ed
    Join Date
    Apr 2019
    Posts
    1

    2014 - a/c turned off due to high engine temp

    The thermostat has stopped working and the a fan under hood running loud.. I did fill up engine coolant, done nothing...please help

  2. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  3. #2
    Drag Racing Champion
    Join Date
    Nov 2017
    Posts
    1,722
    There's lotsa threads with your particular problem.

  4. #3
    Formula One Champion
    Blasirl's Avatar
    Join Date
    Mar 2015
    Location
    Wisconsin
    Posts
    5,778
    I copied this straight off of the other thread ( Ac off due to high temp ) that is in the current lineup.

    Welcome Aboard!

    Use the search bar to your right.

    1st check your Coolant level

    2013 Cruze A/C off due to high engine temp

    Nice reply by Jblackburn


    Don't forget to introduce yourself and your Cruze here.

    Oh and I moved your thread from the new member introduction forum
    Last edited by Blasirl; 04-09-2019 at 07:50 PM.
    Hidden Content "Don't just drive CRUZE!" ༼∵༽ ༼⍨༽ ༼⍢༽ ༼⍤༽

    Hidden Content

    Hidden Content (Hidden Content , Tinted Windows, Husky Floor Liners, shark fin, integral dash cam,Hidden Content , splash guards, Z-Spec Grille, Fogs, Depo smoked turn signals w/amber Diode Dynamics LEDs, Hidden Content UR Rear upper Strut Bar, UR Front Upper Strut Bar) MOTM JAN17 AUG17 AUG18

  5. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

  6. #4
    Handbrake Released
    Join Date
    Sep 2017
    Location
    Antelope Valley, CA
    Posts
    118
    Quote Originally Posted by Ralphalyn View Post
    The thermostat has stopped working and the a fan under hood running loud.. I did fill up engine coolant, done nothing...please help
    Welcome to the forum!!! We had the same problem with our '14 Cruze ECO a couple months ago, turned out to that we had a coolant leak at the Water Outlet Housing & Reservoir Overflow Hose, about $80 to replace both and top off the DexCool.

    NOTE: Do NOT mix antifreezes!!! If you coolant is brown/orange, you have DexCool, and do NOT mix it with green/yellow antifreeze, or vice-versa.
    Chris

    2014 Cruze Eco - Limo-tint (back doors, rear window, & top of windshield), blacked out bowties

  7. Remove Advertisements
    Chevy Cruze Forum
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please select your insurance company (Optional)

Similar Threads

  1. Replies: 0
    Last Post: 02-06-2018, 06:07 PM
  2. A/C Turned off due to high engine temp / Engine overheating
    By Heartofali0n in forum Gen1 Service Issues
    Replies: 4
    Last Post: 07-27-2017, 12:03 PM
  3. Replies: 1
    Last Post: 02-06-2017, 05:23 PM
  4. Normal coolant temp, thermostats, and AC off due to high engine temp
    By UpstateNYBill in forum Gen1 Service Issues
    Replies: 11
    Last Post: 08-18-2016, 12:19 AM

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2