Chevrolet Cruze Forums banner

Recent content by ChevyGuy

  1. Special Coverage #14311: Negative Battery Cable

    Gen1 Service Issues
    The special coverage doesn't cover the '16. If you look at the start of the thread, the program started around Dec 2014. Well before any 2016 was rolling off the line. I'm glad you got it fixed, and while it might be the same part, it wouldn't be covered. I don't know how a bad one got on...
  2. Cruze burning oil like crazy

    Gen1 1.4L Turbo
    Did you clean out the intercooler? And yes, do check the PCV system. It's a very common problem in this car.
  3. Oil leak can’t be found

    Gen1 1.4L Turbo
    First thing I'd do is run the checks described in 2011-2016 Cruze Limited 1.4L PCV System Explained. If the intake valve is missing, the engine will over pressurize and oil will leak from all kinds of places.
  4. A/C compressor not running

    General Discussion
    Check the temperature as reported on the radio. If it's something like -40, the A/C will not run. A number of people have had problems with the connection to the outside air temp sensor. If it gets unplugged and water gets into it, you can get that kind of false reading. The sensor is...
  5. HELP! Could it be my turbo or transmission?

    Gen1 Service Issues
    That's ugly. Is the engine revving up and just not getting power to the wheels? That would likely be a transmission. If the engine isn't running right, then I'd suspect something like a plugged cat choking the engine.
  6. Temperature gage

    General Discussion
    Maybe a couple of problems. First, I'm suspecting one of the sensors is bad so the car isn't sure about it's temperature. The engine is small enough that I've seen multiple reports of the heater being able to suck the heat out of the engine.
  7. 2011 Chevy Cruze LS Stalls while driving. Appears to do a full electrical restart.

    Gen1 Service Issues
    I'm inclined to think that you've got a problem with the car's bus. Anything plugged into the OBDII port? Anything malfunctioning that you didn't mention because you don't care about it?
  8. oil leaking around fill cap

    Gen1 Powertrain
    I'd check the manifold to see if the valve is still there.
  9. California won't buy cars from GM, Chrysler or Toyota

    Chevrolet Cruze News and Reviews
    Keep in mind this is just the state government when buying cars for it's fleet. Not to the residents of California That's a pretty big loophole. And that pretty much eliminates most cars anyway. The real question is if this applies to cross-overs.
  10. Multiple Codes 1.4L Turbo

    Gen1 Service Issues
    The two circuit codes suggests to me you've got a wiring or connection issue. Removing and replacing the hose is doing just enough to temporarily solve the problem.
  11. help pcv issue.

    Gen1 1.4L Turbo
    Check the intake manifold as outlined in this thread
  12. Cruze electrical issues

    Chevrolet Cruze News and Reviews
    Is the battery original? I'd likely on it's last legs. While we think of batteries are for starting, they also filter the power when running. If they open up or short out, you get bad power. Computers hate bad power. The Cruze is filled with computers. I'd also check battery connections...
  13. Throttle sucks

    General Discussion
    I haven't tried it yet, but you might try the sparkplugs suggested in "Hesitation gone" thread. If that doesn't do it, I'd suggest a tune.
  14. pcv or other cause, oil leak

    Gen1 1.4L Turbo
    Read this thread, and check the intake manifold for the orange "nub". If it's gone, the engine will be over pressurized when under boost. That will cause oil leaks.
  15. 2012 Cruze: Sudden Engine roughness?

    Gen1 Service Issues
    The code indicates a misfire in cylinder 1. It could be spark (spark plug or coil pack). But I wouldn't rule out a bad injector or some other cause. Coil is not unusual. Depending on the age of the spark plugs, I'd change them as well. Neither is a difficult job. Well within a DIY who is...
Top