Chevrolet Cruze Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. Gen1 Service Issues
    2012 LT 1.8L, Automatic, 106k miles, Trinidad & Tobago, RHD My car is currently sitting at 170,000 km. This issue has been ongoing for the past year however. When I start the car and drive off, the car accelerates or reverses normally. When I put it into reverse, I need to rev the engine to...
  2. Gen1 1.4L Turbo
    I have been experiencing accelerating issues lately at random moments. At random times when I am driving and come to a stop sign or a red light, then when I give gas after stopping the car does not move at all. Feels like it died, then i'll let go of the gas and hit the gas again and sometimes...
  3. CruzeTalk New Member Introductions
    Hi All !! Does the engine power /accelaration downs when you turn on the AC in Cruze Turbo. Is this normal or there is a problem? DKG
  4. Gen1 Powertrain
    Hi all. A few months ago I was driving on the interstate going about 85 and suddenly the dashboard starting losing power, all the lights were blinking and the digital speedometer was spastically changing to every which number. The car would not accelerate at first, then slowly picked up speed...
  5. Gen1 Powertrain
    Hello everyone, I have a 2012 LS 1.8L. The other day it started to give me trouble when I pressed the gas pedal. It will just run to the first or second rpm, but then suddenly it just won't accelerate anymore not even on reverse. https://www.youtube.com/watch?v=B5WA-jSRfEk Any suggestions...
  6. Gen1 1.4L Turbo
    Has anyone had a similar problem or experience when accelerating modestly a shutter or vibration that generally starts around 10mph and ends around 15mph. The vibration can be felt through the pedals and the steering wheel and seems to be a front end vibration. I don't believe it is suspension...
1-6 of 6 Results
Top