Chevrolet Cruze Forums banner
alternator or battery

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. Gen1 Audio & Electronics
    I'm sure this is posted in the wrong place but I'm new here so it's suiting 🤷‍♂️ I apologize and please move this thread lol Anywho I'm looking to upgrade my alternator for big subs. Does anyone know if there is enough room in the 2012 chevy cruze eco for a second alternator? I think adding a...
  2. Gen1 Audio & Electronics
    I recently purchased a Skar 800rms amp and a 600 rms single 12 Skar sub. My 14 cruze and me is new to modifications and im wondering if this would cause me to have any issues with having to much power for my alternator to handle this set up.
  3. Gen1 Service Issues
    Hello esteemed members, I am new to this forum and have bought a used 2011 Chevy Cruze 1.4L turbo quite recently. I am a student and being my first vehicle I was super excited. Last month however I noticed rough idling and after some research I found out the PCV hissing noise and sure enough...
  4. Gen1 Service Issues
    Any help would be appreciated. My friend drives a 2014 Cruze LT and has been having the car die on and off sporadically for weeks/months now, usually while she's at work or in the morning after the car has sat overnight. She reports to me that the check engine light has been on but when it runs...
  5. Gen1 Audio & Electronics
    Got a 2013 Cruze LT 2.4L. The charging system was acting up but never really had a battery light on. So I replaced the alternator. Now every time I start it up and look at the charging voltage it'll start at about 14.4 and then gradually go down. Sometimes for a while it'll stay at about 13.6...
  6. General Discussion
    Hi guys, I signed up hoping someone might be able to help me. September 3rd I got my wife's Cruze serviced. September 16th My wife rang to tell me the Cruze wouldn't start. An hour later I had a quick look at it, when I was in the area, and could faintly see the hazards blinking on the...
  7. Gen1 Service Issues
    Wondering if anyone has seen this yet. Driving to work today, everything is normal, car works great, no issues. About 10 minutes into my drive the Charge Fault (red battery indicator) lights up on the dash. I toggle through the DIC and my battery voltage is at 11.9. A little while later the...
1-7 of 7 Results
Top