Chevrolet Cruze Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 41 Results
  1. Gen1 1.8L
    I have a 2012 Chevy Cruze. I just gave it to my son. It has 62000 miles on it. It seems that after I handed him the keys the car has nothing but issues. The battery light came on. I put the larger diesel 94R battery in. I replaced the alternator twice. I bought the alternator from Amazon but it...
  2. General Discussion
    Hey all! Tina here. Back story I posted a while back and some of the advice helped.... But I need to figure out my generation. I have tried a Vin search but don't know what I am looking at. I have a 2018 Cruze LT. I am now on my 4th alternator and battery. The Chevy dealership has done the work...
  3. General Discussion
    about 2 months ago (sept 2021), the battery in my 2015 cruze LT died and i had to have it jumped. the AAA guy and the tech at NTB both said my battery and alternator were working properly. 8 days later, i turned my car on, drove 7-8 mins to get breakfast and when i came out to leave about 10...
  4. Cruze Owner Projects
    I found this Cruze build: Chevy Cruze Zombie Killer Thought this would be of general interest, but one question I had was about the alternator. This guy lists, "Chevrolet truck alternator" as an upgrade. Anyone know what truck alternator this guy might be referencing?
  5. General Discussion
    I am switching my alternator to a HO alternator, and am not sure what to do with the charge indicator control wire and the generator field duty cycle signal wires. Any help would be appreciated, also any tips that might make it go easier. A picture of the new alternator is below.
  6. Gen1 1.4L Turbo
    I am switching my alternator to a HO alternator, and am not sure what to do with the charge indicator control wire and the generator field duty cycle signal wires. Any help would be appreciated, also any tips that might make it go easier.
  7. Gen1 Service Issues
    I've been trying to chase this electrical issue for months now. When I'm driving the screen shows anywhere from 11-15v depending on if I'm on the gas or not. When I'm at idle it slowly drops to 12 or below. The headlights and dome light also are dimming and flickering very bad, so much so that...
  8. Gen1 Audio, Electronics & Electrical
    Hey all. 2012 1.4 @117k with Trifecta tune. I've noticed that my voltage is constantly 15.0v on the gauge cluster and in Torque. I tested my battery at work tonight, showing 465cca out of 525. Still starts strong, the battery is 2 years old. The voltage never dropped over a 3.5 hour drive at...
  9. Gen1 Service Issues
    Hi all, when I started my car last Monday with my command start, I looked out the window to notice my hazards flashing. I never saw that before so I went outside and also found my battery light flashing. I had to drive to work and just hoped for the best and drove for about an hour on the...
  10. Gen1 Audio, Electronics & Electrical
    I have a 2014 LTZ and decided to upgrade the alternator to better power my amps. I had previously upgraded the battery to a duralast platinum H7, and done a big 3 upgrade with 1/0 wire. I purchased a 270 amp alternator from CES. They have been great to work with. When I first installed the...
  11. Gen1 Service Issues
    Any help would be appreciated. My friend drives a 2014 Cruze LT and has been having the car die on and off sporadically for weeks/months now, usually while she's at work or in the morning after the car has sat overnight. She reports to me that the check engine light has been on but when it runs...
  12. General Discussion
    Hi all. I am new here. I apologize if I am posting in the wrong place. I have a 2012 LT/RS, manual transmission. I ended up with a check engine light and almost immediate misfiring and stalling at idle. I read the codes and it was reading for the MAP, MAF, and fuel imbalance. I replaced the...
  13. Gen1 Audio, Electronics & Electrical
    Have any of you upgraded your alternator for a high output one looking to add another amp but don’t want to stress out the stock one. If so where did you buy it from and what’s the difficultly of doing it.
  14. Gen1 Service Issues
    Hey guys, I have been running into some issues again with my 103,000 mile 2011 Chevy Cruze LT and need some help. I will start from the beginning. Friday I was leaving for work and noticed the engine sounded a bit weak when I was turning it on. As I went about 1 mile down the road I began...
  15. Gen1 Audio, Electronics & Electrical
    Got a 2013 Cruze LT 2.4L. The charging system was acting up but never really had a battery light on. So I replaced the alternator. Now every time I start it up and look at the charging voltage it'll start at about 14.4 and then gradually go down. Sometimes for a while it'll stay at about 13.6...
  16. Gen2 Service Issues
    After complaining about the battery a second time to a different dealer. And finally getting a replacement. I've been watching my volt gauge. The car starts with 12.2 volts regardless with headlights on or off. Start car up it drops to 12.0 volts. For a couple of seconds. Then jumps back to...
  17. CruzeTalk New Member Introductions
    My 13 Cruze Turbo LT 'died' on the interstate yesterday and I had to leave it 75 miles away. I had the head-gasket replaced about 2 weeks ago. And I had recently been getting strange electrical activity, (Service StabiliTrak, etc.) including rough idle and stalling, (also present before the...
  18. Gen1 Audio, Electronics & Electrical
    Some of you may remember that I bought a bluetooth didgery for my Cruze. Well - one day I suddenly noticed that whenever I was on BT Audio, I had alternator whine and engine-speed buzzing. It's been a few days and I finally got ticked off with it... I thought maybe I had blown the power...
  19. Gen1 Audio, Electronics & Electrical
    My charging voltage never drops below 14.5 and sometimes it get above 15. From what I understand it should drop down into the 12's but never does? Is this a feature that has to be activated by a dealer?
  20. CruzeTalk New Member Introductions
    I have a 2011 Chevy Cruze that is experiencing electrical issues after replacing the alternator. Just recently the Service Stabilitrak warning message came on 2x's. Both times this occurred the radio shut off and came back on once the message disappeared. Any ideas what can be causing this? I'd...
1-20 of 41 Results
Top