Chevrolet Cruze Forums banner
check engine light
1-15 of 15 Results
  1. Gen2 Service Issues
    A few weeks ago my vacuum pump went out and these codes popped up. After I replaced the pump and checked the camshaft for damage (which there was none), I cleared the codes and they popped right back up. So I tried searching online for possible solutions and tried some of them. I changes the VVT...
  2. Gen1 Service Issues
    Howdy. I'm running a 2012 Eco, and I'm getting a pretty intermittent check engine light. I've had issues with the PCV before, and it feels like when the engine light is on, it acts the same as a vacuum leak on the PCV. Slow and sluggish acceleration, turbo underboost, the whole 9 yards. I'm not...
  3. General Discussion
    I have these codes on my 2013 Cruze LT. It also is hesitant to start sometimes and when it does my rpm jumps and it sounds like the engine does too. What can I do to fix this please? I recently replaced the Mass Air Flow Sensor.
  4. Gen1 Powertrain
    Not sure if I posted this in the right place. But I just got o2 sensors, engine air filter, and purge valve replaced about a week ago after codes P013B, P0171, P1101 and P2270. After all that got fixed I’m getting code 0420. Dealer suspects it’s the catalytic converter. 1. Could the o2 sensor...
  5. General Discussion
    Hi all! I’ve been having problems with my Cruze and was wondering if anyone had any insight. I bought my 2013 Cruze 3 years ago. The first summer I had it, it overheated (warning came on to idle engine, engine light came on etc); I checked it out, and it was low on coolant, like nearly empty...
  6. Gen1 Powertrain
    Check engine light came on this morning, took it to autozone and in this order codes read P0171 System too lean (bank 1), P0106 Manifold Absolute Pressure/BARO Sensor Range/Performance, P1101 Intake Air Flow System Performance, Autozone recommendation is to replace fuel injector. But knowing...
  7. Gen1 1.4L Turbo
    I bought my 2014 1.4L Cruze in December of 2018. It ran great until sometime in February, it started almost "coughing" so I took it in to my mechanic. They replaced all 4 spark plugs for me and the problem seemed to go away... Temporarily. The problem came back, so I took it back in a couple...
  8. Gen1 1.4L Turbo
    So far I've changed a few parts in this order: Both O2 sensors, all 4 fuel injectors, serpentine belt, along with valve cover and gaset. Today while I was changing the valve cover thinking it could be a vacuum leak, i stripped a bolt hole. I don't know how to fix that and I also don't know what...
  9. Gen1 Powertrain
    I purchased a 2012 Chevrolet Cruze in 2017. Since then, it has been problem after problem, first the water pump, then radiator. It currently has 151,000 miles, automatic base model, no warranty left. In October a radiator flush and A/C recharge was performed and things seemed fine, my ac was...
  10. Gen1 Audio & Electronics
    So I recently swapped the ZZP 02/midpipe combo for the stock downpipe/midpipe. When I installed the aftermarket exhaust the check engine light. I knew it was going to turn on as it is stated on their website. Well when I switched it for the stock setup the light is still there. Not sure if...
  11. Gen1 Powertrain
    Hello all, My 2014 Cruze LTZ has 48,500 miles on it (6-speed Auto) and the engine light has come on after encountering some transmission lag. This lag happened before, but I thought it was to do with the lack of power once the A/C is on. But tonight while driving back from work the...
  12. Gen1 Powertrain
    Last month when I was stopped idling in my 2011 Chevy Cruze, I noticed the "check engine" light had come on. The car drove fine, and the light went off about an hour later. The same thing happened to me yesterday in the exact same circumstances. I have also noticed my Cruze sometimes shakes...
  13. General Discussion
    The Malfunction Indicator Lamp Function (ok, I added that last word :grin:) just came on when I was driving home. Thing is, my TD only has 144 miles on it--I just got it on Saturday: WHAAAAAAAA...?? OnStar ran the diagnostic check but all they pulled was "error" but nothing indicating what's...
  14. Gen1 1.4L Turbo
    Hi everyone, I'm hoping for a little guidance about my 2011 Cruze Eco M6 before I take it to a dealer. On Friday, I was commuting when I glanced down and noticed the CEL was on. I took it to Autozone over the weekend to have the code scanned, and it came back with P0171: running lean. The...
  15. Gen1 Powertrain
    The check engine light on my 2012 Cruze has turned on four times now right before I need gas and has stayed on for about two days after I fill up. I only have 14,000 miles and have kept up with the maintenance. Nothing seems to affected and the car drives the same whether the light is on or off...
1-15 of 15 Results
Top