Chevrolet Cruze Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Gen1 Service Issues
    Hi, I have been looking at this forum for a while now trying to figure out how to fix the P1101 code I've been experiencing for a while now because I need to fix it before I get my sticker and in order to do that I need to pass emissions. I need help interpreting the freeze frame data to...
  2. Gen1 Powertrain
    Hey y’all I have a 2016 Chevy LT Cruise. I’m downs to buying 3 sensors already and nothing seems to help. Did a leak test came out negative. Cleaned the throttle nothing yet. Did the battery restart nothing yet. I’ve gone 2 different shops and nothing seems to help out the solution. Please...
  3. Gen1 Powertrain
    Hello everyone, I have been struggling with this code for almost 2 years and have yet to find a fix. I have replaced the valve cover and hose, MAF sensor, solenoid purge valve, replaced the charcole filter, and cleaned the throttle body. I havent found any noticable vaacum leaks. I drive a...
  4. Gen2 Service Issues
    I am still getting the P1101 error. I cleaned the old sensor--that didn't fix it. I finally replacing the MAF sensor. I checked the wiring and everything seems okay. Any suggestions on fixing this code? Thanks
  5. Gen1 Service Issues
    My check engine light turned on and I had taken it to two different autozones where they checked my CEL and it gave them the code P1101 for my MAF. I replaced it after about 3 weeks and while I hadn’t replaced it my car would idle up & down when I have my ac on high, like if my engine was trying...
1-5 of 5 Results
Top