Chevrolet Cruze Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-19 of 40 Results
  1. Gen2 Audio/Electrical Tutorials
    I'm planning on buying this bad boy: rolls Stereo Program Limiter, Black (SL33B). Do y'all have any recomendations for tools and cables for installation? I have a chevy cruze 2017.
  2. Gen1 Service Issues
    2014 Cruze LS 1.8L with 182k miles This is my first A/C problem. It blows cold until I restart the car during daytime temps, then the compressor won't engage. Freon pressure is in range w/ compressor running, but is well within the red (high) if not running. Any ideas as to the cause?
  3. Gen1 Service Issues
    Hello all, I have scoured google search results for the past two days in search of an A/C compressor clutch for my 2011 1.4T. I am able to find the whole compressor but not just the clutch or rebuild kit for one. I'd prefer to just replace the clutch so I dont have recharge the system. Has...
  4. Gen1 Service Issues
    Greetings to everyone, i'm from Azerbaijan and new in CruzeTalk, I apologize if this thread is duplicate on forum I've recently get my first Chevy Cruze 2014 LT/RS 1.4L and got a problem with my AC system. The issue is, my AC blows hot air when its sunny or there is high temperature outside...
  5. General Discussion
    My compressor coil went out on my 2012 so I ordered a used compressor that came from a totalled Cruze. I put the pag 46 in and bolted that sucker on there. The pulley spins fine when the belt is not on it, but when I tension the belt and turn on the engine, the pulley does not spin! It's the...
  6. General Discussion
    I have a 2014 Cruze with 220k. Recently my belt kept coming off so I replaced the tensioner to no avail. It kept coming off. I noticed that my AC compressor was loose and appeared to be missing bolts on the ac compressor bracket that sits between the motor and actual compressor. I cannot find...
  7. General Discussion
    Hey all, I have a 2012 LT Chevy Cruze 1.4 engine. I have had this car for a couple of years, and have since got a new compressor, and a new evaporator installed when my AC system started blowing hot air. Just recently I got warm air through the AC vents. I checked under the hood, and the...
  8. Gen1 1.8L
    2011 Cruze LS 1.8L. Long story short, car sat for about 3 weeks and and A/C was working perfect when parked. Go to start the car up and hear a somewhat harsh sound on initial crank, but car starts and runs fine... however the A/C doesn't even attempt to get cold. What I have done so far... 1)...
  9. Gen1 Service Issues
    Hello everyone. New member here and I probably won’t bug y’all much since it’s my wifes car. It’s a 2015 LTZ/RS. I had to put the car in the shop this morning because the a/c quit working. All fuses and relays checked out and the compressor itself wasn’t locked up, just wouldn’t engage. All this...
  10. Gen1 1.4L Turbo
    AC went out the other day and upon further diagnosis I found the retaining bolt came out (or broke) off of the clutch on my AC compressor and the clutch plate was laying on the plastic guard under the engine. I want to replace just the clutch (really just the clutch plate) but can't fine anyone...
  11. Gen1 Service Issues
    A third installment of my hunt to find why I'm not having any cold air come out of my A/C. My 2013, LT/RS Cruze with ~83,000 miles (133,575 Km), has had no A/C for several weeks now. I took it to a dealership and they told me that the radiator fan assembly needed to be replaced. Because they...
  12. Gen2 Powertrain
    Hey guys, does anyone here know the dimensions of a compressor wheel on a 2018 Cruze 1.4T? Was wondering if this will fit or if it's bigger? https://www.dieselsite.com/wickedwheel6.5L-2.aspx Basically I would like to install a larger compressor wheel in the stock turbo. Like I did for my...
  13. Gen1 1.4L Turbo
    Hoping to find some help here. 2015 1.4L AC blowing ambient temp/warm air. Fuses, relays all working. Manifold gauges read high on the low side, and low on the high side, with the engine at running temp...without the compressor engaged. Nothing I can control gets the compressor to engage...
  14. Gen1 Service Issues
    All, Recently I had to get my engine coolant system and the thermostat system replaced due to a faulty system and while I was driving the car, it would constantly say AC off due to high engine temperate. Since my coolant/thermostat has been fixed, my AC has never turned back on and now my...
  15. Gen1 Service Issues
    I have a 2011 Cruze LS (automatic) with 77k miles on it and my AC Compressor has completed failed. After taking it to two mechanics, neither could pinpoint a leak or physical damage but both said the compressor is not working. I asked about electrical issues, issues with the hoses/magnetic coil...
  16. Gen1 Service Issues
    The air conditioning on my 2013 LT, with 30000 miles, recently turned warm. The compressor clutch stays engaged just for a few seconds, then drops out. Then engages ... then drops out. Repeats indefinetely. Doesn't stay engaged long enough to do any cooling. I used a low-side gauge, and it reads...
  17. Gen1 Service Issues
    2012 Cruze LT ac not working ..did have some compressor clutch noises ..fuses seem ok and swapped a relay and didnt help....when in ac mode the cooling fan does not run ..but it does work with temperature ..seems electical but dont know what else it could be
  18. Gen1 1.4L Turbo
    Hello all! I have a 2011 LTZ in which the a/c compressor clutch just failed. The car has around 120k miles so I plan to overhaul the a/c system and wanted to run my plans by you guys to make sure I am ordering the correct pats and not missing any steps. -I have a local shop that will...
1-19 of 40 Results
Top