Chevrolet Cruze Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. General Discussion
    Good afternoon, cruze-talk teammates! After replacing almost all parts of the coolant system from reservoir, to hoses, to water pump, I still have an active leak coming out of a hose/coupling underneath the exhaust manifold and heat shield on the driver's side front of the engine. It leaks...
  2. Gen1 Service Issues
    i had my water pump replaced probably a year ago and then it randomly started leaking really bad. i replaced it myself and ended up getting a refund from the dealership after talking to them. (probably shouldve called them first and just had them replace it for free in the first place) the pump...
  3. Gen1 Service Issues
    I had a really bad leak from my water pump so i replaced it and it stopped for a few days. now its leaking again i think thru the bearing and impeller because its dripping down from under the pulley mount. any solutions?
  4. Gen1 1.4L Turbo
    It's beyond me why would they not bother to include a simple coolant level sensor into this car, I almost got stranded with almost no coolant left if it wasn't for me checking it during a trip when I smelled antifreeze, fortunately I had some extra in the trunk knowing these cars have issues...
  5. Gen1 Service Issues
    Last week I noticed that my 2014 1.4L was leaking coolant from what appeared to be the thermostat housing (ended up being cracked). This solved the majority of the problem but there is still a slight leak. See the imagine below, It is now leaking right between the water pump and thermostat...
  6. Gen1 Service Issues
    So im leaking coolant from the spot im pointing at in the picture. It is a large hose coming from bottom of radiator to throttle body? But i didn't find anything about it in particular about it in my search.
1-6 of 6 Results
Top