Chevrolet Cruze Forums banner
corrosion
1-11 of 12 Results
  1. Gen1 Audio & Electronics
    I was getting the dreaded Dynamic Duo - Service Stabili-Trak / Traction Control warnings [EDIT: forgot to add ABS light as well](No codes come up on my Action Pocket Scan Plus reader though) and thought, I just added the Big Three – well, the two grounds anyways and I just had my ground cable...
  2. Gen1 Audio & Electronics
    I popped the hood tonight and looking at the neg terminal there was a lot of corrosion. The car starts fine. Just seems to be missing a little power as of late. The reason I popped the hood. I was going to look at my plugs with 73K then I noticed the corrosion. Have not had a chance to...
  3. Gen1 Diesel General Discussion
    Has this happened to anyone else? My 2014 has just over 40K miles on it. I'm not that pleased with this at all!
  4. Gen1 1.4L Turbo
    Been misfiring and took a look at the plugs and Springs. Slight corrosion on 1 2 3 and real bad on 4. Bought new plugs and had new Springs but any idea how to clean the corrosion off the coil? I plan on buying a new rail when I have the money.
  5. Gen1 Powertrain
    So i decided to switch out my spark plugs today. Have to get the $150 part because i tore a boot. when i pulled out the far right park plug and the one next to it i noticed why it was stuck so bad. The far right spark plug is covered in white corrosion. Does anyone know why that would happen...
  6. General Discussion
    Anyone else have rust building up on their rear drum covers? I was outside smoking a cig and noticed a fair bit of rust on my passanger side rear brake cover, figured I'd share lol. Any ideas on how to go about getting rid of eye sore?? Jw.
  7. General Discussion
    "Covered for 3 years/36,000 Miles GM is committed to ensuring satisfaction with your new vehicle. Your dealer also wants you to be completely satisfied and invites you to return for all your service needs, both during and after the warranty period. To help keep things in proper working...
  8. Gen1 Audio & Electronics
    Hi all, My setup: noname 500w amp and 12" Alpine sub so about 2 months ago I posted a thread on here because my power connection at the battery terminal had corroded so much that it melted and destroyed my amp power wire and fuse holder. (the actual fuse didnt pop until everything was...
  9. Gen1 1.4L Turbo
    While I was chasing a loose spark plug issue, I noticed that the coil spring for #4 cylinder was corroded. The coil itself looked like this (sorry for the poor picture, there's a lot of green corrosion on the bottom): I am stumped how a coil could have corroded. The #4 spark plug was...
  10. Gen1 1.4L Turbo
    Poking around the engine compartment of my '12 Eco, I found what appears to be significant corrosion on the wastegate actuator rod where it is exposed to the elements. It's not enough to cause it to fail yet, but it is a concern long term. The rust was advanced enough to be flaky, so I'm...
  11. Gen1 Wheels, Tires, Brakes, & Suspension
    My 17' alloy rims on my 2011 2lt Cruze are starting to corrode around the center cap area. Anyone else experiencing this on their alloy rims? Im still covered under the three year bumper to bumper warranty, will gm replace them? Any advice on how to repair and prevent it from happening further?
1-11 of 12 Results
Top