Chevrolet Cruze Forums banner
ecm
1-20 of 29 Results
  1. Gen1 Service Issues
    Hello, I recently bought a forfeited 2014 Cruze with 34k miles. It did not have a key and would not start once I had one made/programmed. I have been working on the no crank, no start condition off-and-on since I got the car (see my previous posts here and here) in which I have made some...
  2. Gen1 Service Issues
    So, I recently bought a 2014 Chevy Cruze LS (1.8L) that was unclaimed and without a key. I got a key cut and programmed (see more about that in my previous post) and everything seems to be in order as far as programming goes. The key in the ignition switch shows up as a master key which even has...
  3. Gen1 Service Issues
    Let me preface this by saying this is my brothers car. About a month or 2 ago, He overheated the car. In the process of trying to get the coolant levels right, overheated it again. This time, it shut down and was nearly impossible to get it home, but it jumped, and we limped it home. We had a no...
  4. Gen1 Service Issues
    Hello all, I hope you're doing well. I've quite a few issues with my 2016 Chevrolet Cruze Limited LT (50,000+ miles). I'll write my issues and any mitigating steps I've taken in a chronological order: - About a month ago, my car started rattling, and per a few YouTube videos it was very...
  5. Gen2 Powertrain
    That's what the forum reports as the knock sensor, which has triggered the CEL twice this year, back in May and today. It cleared itself each time. I've been running 92-93 octane. Since I have the powertrain warranty, should I take it in? If I had the Trifecta tune on the ECM, should I flash...
  6. Fuel Economy
    Hi Everyone! Can anyone guide me through resetting my ECM for cruze 2016 2nd Gen. I'm getting poor gas mileage and I suspect the ECM as there's no check engine.
  7. General Discussion
    I have an Australian built Holden Cruze 2012 equipe JH 1.8 with a manual transmission. After washing the engine bay. Car would not start. Have had it looked at and have been informed that the ECM ( engine control module) is water damaged. It sits next to the battery and is not the ECU which is...
  8. Bcm

    Gen1 Audio & Electronics
    I HAVE A CHEVY CRUZE 2011 LS MODEL WITHOUT CRUISE CONTROL SO I GOT A BCM FROM ANOTHER CAR SAME MODEL that have a crusie control & WAS THINKING OF INSTALLING IT ON MY CAR BUT I HEARD THAT I NEED TO REPROGRAM THE NEW BCM WITH MY ECM AND ITS DIFFICULT AND NO ONE IS DOING IT ANYMORE SO IS IT...
  9. Gen2 Audio & Electronics
    Problem is described in the title. No engine light or other indicator showing there is any problem. Help?
  10. Gen1 Service Issues
    Looking for some advice. After our 2012 Cruze's 1.4 engine reaches operating temperature, the engine begins to surge and lose a significant amount of engine power. In fact, the engine can't even maintain speed with cruise control engaged. Sometimes the CEL illuminates and other times it just...
  11. Gen2 Service Issues
    Forgot to post about this the other day. Driving to work, cruise control set at 72 mph, and all of a sudden I had absolutely no engine power. Reduced engine power showed on my display. I coasted to the side of the freeway (during congested morning traffic) and tried to restart. Nothing. Threw...
  12. Gen1 Service Issues
    Hello everyone, thanks for hearing me out. Recently started having issues with my 2011 Chevy Cruze w/70k miles and have read a few posts here about it but looking for some definitive answers. About a week ago, the Stabilitrack and Traction control messages came on and then shortly after the...
  13. Gen1 1.4L Turbo
    I am currently in the process of converting to flex fuel, and need to know how to correctly attach my wires into the ecm harness... It seems like a fairly simple thing to do but I want to know the 'proper' way so that I don't screw up my ECM. Thanks!
  14. Gen1 Powertrain
    Every now and then when I start the engine and Ultra Gauge will prodice "ECM Voltage Too High" alert. Measured ECM voltage at that time is 14.90. A minute later and voltage drops to ~14.50. This looks pretty normal to me and I would raise the UG ECM voltage limit to say 15.00 but wanted to make...
  15. Gen1 Service Issues
    I've had my car for 3 years now (2012 Cruze LT/ 4-Cyl, Turbo, 1.4 Liter) and have a total of 24 service reports on my record. They have replaced (under warranty) 12-13 parts on my car since I have been the owner. I bought it used with only 20k miles on it, within a few weeks of having it my...
  16. Gen1 Service Issues
    2012 Cruze Automatic 1.4T - I've had the car myself for about 2 years. I had an issue with the car electronics acting funky and that was fixed with the negative battery cable recall. Car worked fine since that was done in November of 2015. The car was in the dealership for the ECM programming...
  17. Fuel Economy
    This is long overdue, but better late than never I guess. Car info: 2012 Chevy Cruze LT Automatic 1.4L 66,2xx miles Location: TX Regular Gas(87 oct) No codes or warning lights Engine Air filter changed- Jan 2015 Spark plugs gapped- This past week Tires properly aired(bought new July 2015) I...
  18. Gen1 Diesel General Discussion
    Has anyone else noticed this? The last two times that I interrupted the regens first at STM 11 and second at STM 19, the regen process did not resume when I restarted the car. The STM gradually built back to 22 with normal driving and then restarted the regen. I think this makes more sense...
  19. Gen1 Service Issues
    Had the CO reprogram on the engine control module and it destroyed the driveability with possibly a 10~15% loss of power. Under some circumstances is is almost dangerous to drive. Lack of power, engine misfiring, push on the gas pedal and it will actually slow down for a couple of seconds. The...
  20. General Discussion
    I just received a notice to have the dealer reprogram the engine control module (ECM) to revise the fuel enrichment strategy on my 2013 Cruze eco. My question, is this going to change my fuel economy? :(
1-20 of 29 Results
Top