Chevrolet Cruze Forums banner
failures
1-6 of 6 Results
  1. Gen1 Service Issues
    I have a 2016 Cruze LT with 108k miles I changed the battery now having a ton of issues. 1) Inside lights don't work 2.) Radio and screen doesn't work 3.) Windshield wipers won't work 4.) Driver side high-beam won't work 5.) Random turn-signal issues.. Anyone have any solutions I'm pulling...
  2. General Discussion
    My 2012 chevy cruze check engine light came on with multiple failures P0335, P0597, P0806, and P16f3. My question is why would everything fail at once.
  3. Gen1 Diesel General Discussion
    Just hit an interesting (and very promising) milestone today. My EGT sensor failed at 61K-ish miles and I am now just about to turn 162K miles and I realized, I have not needed to replace any emissions components whatsoever since 61K miles. I know that's one of the favorite things to complain...
  4. Gen1 1.4L Turbo
    Apologies in advance if someone already did this. Decided to dissect one of my old valve covers to see what it is that fails in them, here it is. Picture is of the diaphragm directly under the cap where the vacuum leak occurs. Apparently the diaphragm develops a crack over time and is the...
  5. General Discussion
    The letter stated that our 2011 Chevy Cruze 'may' possibly have a defective or problem with the coolant pump, anything related to the coolant area. To make a long story short, the letter said that IF you think you may have a problem with yours to bring it in or if you alreAdy paid for it, you...
  6. General Discussion
    anyone having issues with loud injector noise and / or remote ignition starts with the 2012 cruze ?
1-6 of 6 Results
Top