Chevrolet Cruze Forums banner
high
1-19 of 173 Results
Advanced
  1. Gen 2 Tuning/Modifications
    I couldn't seem to find any videos for the valve using a CAI. If anyone is curious this is how it sounds.
  2. General Discussion
    Hi all, Please advise. I have a 2011 Chevy Cruze Eco with just under 144k miles. I purchased the car at 100k and have taken great care of it in my 3 years of owning. No major issues so far. I want to know how far this car can go as best I can without knowing how it was taken care of in the...
  3. Fuel Economy
    I sold my 2011 Cruze ECO Manual, so I will no longer be adding to this forum. Although the engine had the usual 1.4L issues - water pump/coolant leak, failed PCV in the valve cover, and the trunk open switch failed a few times, it was a fantastic car on fuel economy, with very high MPG. I put a...
  4. General Discussion
    The thermostat has stopped working and the a fan under hood running loud.. I did fill up engine coolant, done nothing...please help
  5. Gen2 Powertrain
    BNR is proud to announce the immediate availability of our High Performance Bypass Valve for the Gen 2 Cruze 1.4T! Faster Spool More boost, sooner More boost, longer Increased throttle response MUCH louder chirp/blow off sounds from the turbocharger, especially with an aftermarket intake...
  6. Gen2 Audio & Electronics
    2018 hatch. I have a 12 in infinity 1242w sub in a sealed box with a 1000w class d dual amp. When I turn up the volume to anything above 40-45, the bass starts to cut out. I had the system professionally installed & don’t have much knowledge on audio system. Any thoughts?
  7. General Discussion
    Hi, I have a BNR tune with nearly 23psi which starts dropping at 4000rpm and ends up at about 15psi. The stock wastegate actuator is on it's way out as it used to only drop to 17psi. My question is: Does the boost drop in high RPM only because of the weak stock actuator or is it because it's a...
  8. Gen1 Powertrain
    Hi Seasoned Cruze drivers, I am driving a 2011 Cruze 6AT. While driving on the highway or city roads, my speedometer will randomly drop to zero, and the RPM went up above 3K. There is no power to the wheels no matter how I step on the accelerator. Most of the time I managed to roll the car to...
  9. General Discussion
    Hi all....I am looking for a Cruze for my grand daughter (1st car). She doesn't have a whole lot of money. Would like to pay cash for something. I see a 2011 with all the options, only thing is, its got about 130,000 miles on it. Mazda dealer says its a trade in. Wants about $6000 cdn with...
  10. Gen1 Service Issues
    Hi! I’m new to posting but have been following this for quite a while. I recently moved from Oklahoma (ele. 800 ft) to NorCal (ele. 5000 ft), and my poor Cruze has been having issues. I’ve looked at other posts and tried to identify what was going on but haven’t quite nailed it down. I live 2...
  11. Gen1 Powertrain
    Repectfully request advice: Low O2S2 voltage & high LTFT caused by bad Catalytic Con vehicle: 2011 Cruze LT 1.4L turbo, 67K miles (This car was not properly maintained by the previous owner.) Long Term fuel trim ~ 12.7 O2S2 (down stream O2 sensor) voltage .67 vacuum at idle after warm up ~...
  12. Gen1 1.4L Turbo
    Intermittent. Happens when I shut down the car. Should I replace the fan, or is there something else amiss here? https://www.youtube.com/watch?v=PSemsnJdpmM&feature=youtu.be
  13. Gen1 Service Issues
    I was getting the “a/c off due to high engine temperature message” and could see my car was running hot. Then it started to overheat so I pulled over immediately and turned it off. My mechanic said the part that holds the coolant was cracked. He said there wasn’t damage to the car from...
  14. Gen1 Audio & Electronics
    So I am a car audio finatic. I like my music to sound great and also blow your flipping socks off. I currently run 4 JL audio door speakers (50 watts per channel) and 2 12 in sundown audio SA series speakers (1500 watt combined) on a 1500 watt amp. I have done a big 3 upgrade and installed a...
  15. Gen1 1.4L Turbo
    Hi guys, been battling a rich idle condition for a while now and cant figure it out. I run 42lb injectors on E85 from BNR. Ive gotten a P0172 code once about 7 months ago but that's it as far as codes go. I got the code when I installed my AEM wideband on a previously installed ZZP downpipe...
  16. Gen1 1.4L Turbo
    Hi, I was just wondering if anyone would know why my car is idling higher at start then usual? Normally it sits just below 1000 rpm but has been idling around 1500 for 10-20 seconds then drops down to a little below 1000 rpm this just started happening about 5-6 days ago. Also I find when I...
  17. Gen1 Service Issues
    Just bought this - needed something... 2012 - 1FL model 210k Miles Had some check engine lights... Misfire Cylinder 1 (Fixed) MAP Sensor (Fixed) Turbo boost sensor (Just fixed - erased code - nothing back yet) Also replaced the Valve cover for the **** of it, as I've seen their prone to...
  18. Gen1 Service Issues
    Hello, First off, I apologize if this is in the wrong thread. Secondly, I have read several other threads about the same topic but still having issues. My car randomly shuts the ac off due to high engine temp, temp gauge goes dead, and just today the check engine light came on but I haven't had...
  19. Gen1 Service Issues
    Hi, I got this message ac off due to high temp and my fan keeps running with my temp gage stuck at cold. I have a 2012 chevy cruze and I am thinking its a bad thermostat? Has anyone experienced this issue?
1-19 of 173 Results
Top