Chevrolet Cruze Forums banner
oxygen
1-7 of 8 Results
  1. Gen1 Service Issues
    I had to replace an O2 sensor in my 2012 Cruze Eco Manual at 50K miles. I have the bank 1 code going off again with performance issues and poor gas milage. The second O2 sensor was a Bosch and lasted 70K miles. Anyway recommend Denso over Bosch? Does that sound like the usual life expectancy...
  2. Gen1 1.4L Turbo
    Anybody use one of these on the mid pipe until they could afford a tune just to prevent the check engine light?
  3. CruzeTalk New Member Introductions
    Hello, My 2010 Cruze has given me nothing but trouble since I bought it only 7 months ago. Its latest issue is the engine light has come on (right before I was going to advertise to sell it) and I took it to a honest mechanic who plugged it into the computer and gave him an error with the...
  4. Gen1 Engine/Transmission Tutorials
    How-To: Replace Downstream Oxygen Sensor Overview: Under certain conditions, the downstream oxygen sensor may short out and fail. If this happens, the vehicle will throw a check engine light and report codes P0138, P0140, and possibly P013E. A replacement of the oxygen sensor is required...
  5. Gen1 Diesel General Discussion
    Took it to the dealer today for the engine light on code PO133 for the oxygen sensor. They had to run additional tests before GM would authorize the replacement. The part is being overnighted and we should have it back tomorrow. 4200 miles on her so far.
  6. Gen1 Diesel Technical Discussion
    This CEL occurred twice after highway travel immediately after decelerating when getting off. The CEL was reset by 2 different dealers 3 times now and has still recurred again. The Oxygen Sensor part required is on an unavailable status since Nov. 2013. This has not affected the driveability of...
  7. Gen1 Powertrain
    I have replaced both oxygen sensors at 115k both worked properly and did not put out any error codes. I like to think my efficiency and performance increased slightly. For the past 10k miles I have noticed random 100 - 200rpm idle losses while in neutral and stopped that really only last a...
1-7 of 8 Results
Top