Chevrolet Cruze Forums banner
reduced engine power
1-11 of 12 Results
  1. Gen1 1.4L Turbo
    About 2 weeks ago, I got the Low Oil Pressure -- Stop Engine message. After finding a safe place to pull off and wait, I followed the guidance of what I was reading and had it towed to a repair facility. My mechanic checked the oil pressure and said it was fine (65 lbs.). He replaced the oil...
  2. Gen1 Diesel Technical Discussion
    Dear Cruzetalk.com I am from Denmark and writing on my 2013 Chevrolet Cruze which thus far has run 125.000 miles without the hint of a problem. We recently had it for the regular mileage check up and following mandatory testing on Thursday the 17th of June . No issues were present. However we...
  3. Gen1 Service Issues
    Hi All, When I tried starting my 2014 Chevy Cruze LTZ, 1.4L, the engine fired up, then immediately died down, giving warnings of "Reduced Engine Power", "Service Traction Control", and "service Stabilitrak". Additionally, there was a bit of flickering with the lights (made worse if I turned on...
  4. Gen1 Powertrain
    2013 LT 1.4T auto Okay so I can turn a wrench but when it comes to wiring/electrical systems I’m a bit of a caveman so bare with me.. and to make this clear this is not my car, it’s my girlfriends. early today she calls me panicked saying her cars freaking out and broken, she tells me the...
  5. Gen1 Powertrain
    One month ago my 2015 Chevy Cruze 1LT started having issues. I financed the used car 8/29/19 and it had just under 80,000 miles on it. I replaced all 4 tires tires on it two days later due to three of them being bad. Towards the end of April while I was out of work the check engine light came on...
  6. Gen1 Service Issues
    We have a 2012 Chevy Cruze, we have had it since August this year and we keep getting Engine Power Reduced along with a Service Stabilitrak message with the check engine on. We are able to temporarily get the car going again by turning it off and waiting at least 15 seconds then usually can be...
  7. Gen1 Service Issues
    hey guys first post. 2015 cruze lt 19,xxx miles, about to get serviced for the third time for the infamous service stabilitrak, service traction control, reduced engine power etc issue. Symptoms: Drive ~60 miles highway using cruise control most of the time. park, go inside somewhere for 30...
  8. Gen2 Service Issues
    Hi All, I've looked through and found a lot of similar but nothing quite the same. So yesterday once I came back into the city after a 300km road trip that had some rain and mud as there was some highway construction my 2016 LT Turbo had a weird lack of power especially when accelerating from a...
  9. Gen1 Service Issues
    I have a Chevy Cruze Eco 2012 model with 68,000 miles on it. Since weeks now the reduced engine power light comes on--took it to the dealership and they kept it for a week before telling me that they could not find a problem. And they had removed the error code. Also mysteriously my coolant...
  10. Gen1 Service Issues
    Hi, I ran out of gas today in my 2012 Cruze (oops...). Got a close relative to bring me gas, then I got right to the gas station and filled up. The Reduced Engine Power warning is still on my menu when I start the car up. No other lights or anything on, just that one and if I 'flip' through the...
  11. General Discussion
    Picked up my Cruze today, on the way home the "Malfunction Indicator Lamp" came on :(I called the dealership and I am taking it in tomorrow. It is a 2012 Eco that has 24k km on it. I also checked under the hood about 15 minutes after I got home and it was quite hot. Is that normal for this car...
1-11 of 12 Results
Top