Chevrolet Cruze Forums banner
side
1-17 of 257 Results
Advanced
  1. Gen1 Service Issues
    I looked under my Cruze and noticed that the hose covered in plastic tubing that runs from front to rear has a wet spot in one part of it. I’m guessing it’s the brake line? I’ve notices my brakes have been feeling weird for a while now..is this why?? Brake fluid doesn’t seem to be loosing any...
  2. Gen1 Powertrain
    I seem to have a coolant leak down on the lower radiator hose(or so im assuming) The problem is it downs behind the passenger fog light and above the engine pan/skid plate and I cant see any way to easily access this without tearing apart the whole front corner of the car... Am I missing something?
  3. Lighting
    Hi there so I have recently been working on a new bumper and I have filled in my marker lights and I would like to make cuts in the fenders a install marker lights there. I would like to install a set of oval amber side marker lights I like the style from the jetta. I found a pair pretty cheap...
  4. Gen2 Audio & Electronics
    The lock/unlock switch on the driver side door is no longer working. The system works including the remote fob, but not the button on the door. Dealer wants $110 to diagnose. Anyone fix/repair this themselves? Model year 2017; LT Thanks.
  5. Gen2 Service Issues
    I would like to know how to replaced the 194 side marker bulbs in my 2016 GEN2 Cruze with the projector headlights. There is a large and small round access plug on the back of the headlight assy. The larger one gives access to the headlamp bulb and I assume the smaller plug gives access to the...
  6. General Discussion
    Hey folks. I just replaced the turbo charger on my '13 cruze eco and im noticing white smoke and a burning smell from the catalytic converter side of the turbo. I checked the exhaust and i dont see any smoke coming from there. Could the cat be clogged?
  7. Gen2 Audio & Electronics
    It might need a resistor, canbus harness or the light is defective? Can anyone tell if the resistor or harness already installed? Here’s a video of the flickering light https://youtu.be/EgWMEhScEA4
  8. Gen1 Audio & Electronics
    I was hoping this problem would not resurface after I made every attempt to protect these Blind Spot Modules (Part # 22971842) from the elements this past summer. I very neatly covered them up with Gorilla tape and self-fusing silicone tape (see picture). I did this since these modules are...
  9. Gen1 Wheels, Tires, Brakes, & Suspension
    Hi all, first time poster on the forums. I have a 2014 Chevy Cruze LT with 55k on it. Been noticing this issue for a few months now, but it hasn't really gotten considerably bad until recently. I'm hearing a noticeable rattling/clunking noise coming from the front passenger side wheel that in...
  10. General Discussion
    Howdy, For those that have replaced their CV axle or seal, did you need the little plastic ring that the dealer recommends to get the axle back in? Thanks!
  11. General Discussion
    Hi guys, I'm considering buying a 2014 Cruze LS with only about 28k miles. The car looks and runs great, but upon further inspection, I noticed a small leak to the right of the engine, under what I think it's the coolant hose. It is not a very big leak, as it only accumulates in the area, not...
  12. Gen2 Service Issues
    My '18 1.4L hatch's passenger side airbag light is always on. It will indicate whether the airbag is on or off but it never goes off. Is this a 'feature'? My other car's lights simply don't illuminate when there's nothing too heavy on the passenger seat and it only comes on when I put a few...
  13. Gen1 Diesel General Discussion
    Hey guys. Starting leaking antifreeze couple days ago and trying to find where it's coming from. Cant seem to find exactly where it's coming from. Anyone have any experience with the cooling lines water pump yet. Any help is greatly appreciated
  14. Gen1 Audio & Electronics
    Does anyone know what fuse is for the side detection system? I can’t figure out which one controls it.
  15. Gen1 Audio & Electronics
    Hello all, I had an issue that started with "Service Side Detection System". Through diagnosis I figured out the harness was bad (blowing fuses with no sensors plugged into it), so I replace it. I also replaced the two blink spot sensors in the rear bumper. They were both corroded extremely...
  16. Gen1 Wheels, Tires, Brakes, & Suspension
    I have diagnosed the problem to be a CV axle, so i ordered a new front drive side axle. It arrived today and the axle looks way too long, would anybody possibly have a video of a front driver side axle replacement or a link or part number for an OEM front driver side axle, I got a duralast one...
  17. Gen2 Service Issues
    Up to 2018, there was an access panel to get to the mirror mounting. The mirror was mounted on the front of the window panel, where the old vent window used to be back in the day. Now, the mirror is mounted on the door itself and there seems to be no specialized or dedicated access panel. Anyone...
1-17 of 257 Results
Top