Chevrolet Cruze Forums banner
sluggish
1-10 of 10 Results
  1. Gen1 Service Issues
    Hi everyone, first time poster here. I have a 2014 Cruze 1.4L Eco Automatic with 120,000 miles that is is showing a P0299 code. I noticed a few days ago that the car started acting what I can best describe as very "sluggish". The car feels really heavy and slow when accelerating and is worse...
  2. Gen1 1.4L Turbo
    I have a 2014 Chevy Cruze lt2 with the 1.4 turbo. When taking off from a stop light it has like barely any power and move very slow through the low end then about mid range it kicks in and takes off. I just bought the car week and a half ago from a dealership certified pre-owned car with 19,000...
  3. General Discussion
    I've searched the forum and saw a few threads about this(all old) and have thus decided that i'm going to start using some premium gas and when my engine cools down i'm going to check my plug gaps. Outside of this, and a pricey tune, what else can I do to get this Cruze to run right in this...
  4. Gen1 Diesel General Discussion
    I think this is normal, but does anyone notice their TD is extremely sluggish when it first turns on coming out of a stop? Feels like it's tugging a trailer, but this sluggishness quickly goes away in the first mile or less. Thanks!
  5. General Discussion
    Lately I feel like my Cruze gets REALLY sluggish. I have been running the A/C fan speed on 2-3 but it's been a 100+ degrees EVERY freakin' day here where I live in So. Cal... so it's gotta be on to not die from heat exhaustion, and my car unfortunately does not get garaged or parked under a...
  6. Gen1 Diesel General Discussion
    I recently moved to a house from an apartment, and now my whole commute to work is on streets which are 25-35-45, with lots of lights. I have noticed that if I am cruising at a fairly low speed, 25-35 typically, and I need to pass someone, I will floor the accelerator, and the transmission takes...
  7. Gen1 Powertrain
    I have a 2012 Eco and I recently have done the resonator delete and fixed my spark plug gap. I was enjoying the extra peppiness but I've been noticing at times the cruze is extra sluggish. It has been hot here and I have been using the a/c and I haven't determined that's the sole responsibility...
  8. General Discussion
    I purchased a Used 2011 Cruze LS - Automatic Transmissions with the 1.8L Engine, I test drove it and everything seemed good, the car fax was clean. But the more I drive it, it is just incredibly sluggish, it seems like I barely touch the gas and the RMP's jump up to like 3 or so, the "take-off"...
  9. General Discussion
    2011 Cruze Eco, automatic transmission I've had my Cruze for about six months. Had a lot of transmission issues for the first few months. Driving was really jerky and had almost no torque. Transmission began smoothing out at about 5,000 miles but I still had a lot of problems getting any power...
  10. Gen1 Service Issues
    Hello, I have the Cruze 1.4T with automatic transmission. I noticed when first driving out, especially in cold weather, it seems the AT is very slow and unresponsive in moving through the gears. Sometimes I have to push 3000+ RPM's for several seconds before the AT "decides" to upshift to a...
1-10 of 10 Results
Top