Chevrolet Cruze Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 78 Results
  1. Gen1 1.4L Turbo
    I have had this car since February 2022 and it stopped working after a few months because of the coolant system I’m not sure exactly what happened but the water outlet pipeline on the driver side broke off inside the radiator hose that’s located on the driver side and leaked coolant everywhere...
  2. Gen1 Service Issues
    Hoping to get some suggestions for troubleshooting. Recently had a P0599 code and noticed my radiator fan had stopped working because the ground cable wire from the fan had come off the bolt. Found a 6m x1 hex flange nut to secure ground cable and fan started working normally again. Code went...
  3. General Discussion
    Has anyone found an upgrade for the thermostat on the 1.4 ecotec 2011-2016 first gen cruzes? I'd like to replace the plastic one for a metal one. I found the upgraded metal coolant outlet for the driver side outlet so I'd like to replace both at the same time.
  4. Gen2 Diesel General Discussion
    i am a youtube mechanic so bare with me im replacing a thermostat in a 2018 chevy cruze lt 1.4L and i cant find anything on a 2018 thermostat in trying to find the location of it but all i can find is 2016 and older models where the thermostat is on the left side of the engine but i oculdnt...
  5. General Discussion
    Hello, a few months ago my car started getting a warning, AC off due to high engine temp, immediately after turning it on, and the fan runs constantly. I was told that it could be a tempature sensor. I also notices when this happens the temp gage doesn't move. I was told the fan is a failsafe in...
  6. General Discussion
    Hi everyone, I'm glad to be here. I have a '14 ECO manual, 90k miles. I replaced the thermostat about a year ago and she was running great til now. The temp guage barely moves on a 20 mile ride to work (yes these cars warm up slow, but not this slow) so heat is pathetic and we're down to the...
  7. Gen1 1.4L Turbo
    Hello Everyone, I have a 2015 Chevy Cruze with the 1.4 L engine and I have a question concerning cooling issues. Just today the temp outside was 37° F and half way to work after warming my car up for about ten minutes, I noticed the temp Gauge hadn't moved beyond the quarter mark on the dash. I...
  8. Gen1 Service Issues
    2014 Chevy Cruze, 1.8L, message popped off saying “ac off due to high engine temp”. Replaced the thermostat, therm housing and water outlet, temp sensor ( all came pre assembled, ACDelco, from RockAuto), everything is torqued to spec, but upon starting, the message didn’t go away and the fans...
  9. Gen1 1.4L Turbo
    So I finished a head job recently on my cruze and I have hopped through a bunch of hurdles as is, but now it overheats! the coolant boils over into the revisor tank and overflows... great! First thought of course is that I messed up the head gasket, but I got a new head, felpro gasket, new...
  10. Gen1 1.4L Turbo
    What’s up hey I’m a new member to the site my wife has a 2015 LTZ 1.4 turbo and all was good after we got it back from dealership after about a month the temp gauge stops working well thus being in winter I was using the heat so no need for a/c then on the dash it issued the “a/c off due to...
  11. Gen1 Service Issues
    Hi all, So I've read few articles on the above mentioned error and attempted a few fixes. So please bear with me and don't think this is just another repeat post. I've attempted a number of fixes already. In short, my wife's 2012 cruze (1.4L) was throwing the above error. My reader called it...
  12. Gen1 Service Issues
    I have a CEL for po128 and have wondered whether i need to replace a thermostat or coolant temperature sensor. I originally thought i would need a new thermostat although the heater in the vehicle is working just fine. The only thing that I have noticed is the coolant temperature gauge has not...
  13. Cruze Owner Projects
    Hello, I'm having an issue with my 2011 1.4, Im showing codes P0102, 113, 0B7, and P07E8.... I've changed the valve cover twice. Tapped and Re tapped the second time to get a tighter seal,( Rtv is absofu**inglutely pasted on this thing everywhere) compliments of shear anger at the project. MAF...
  14. Gen1 Service Issues
    Last week I noticed that my 2014 1.4L was leaking coolant from what appeared to be the thermostat housing (ended up being cracked). This solved the majority of the problem but there is still a slight leak. See the imagine below, It is now leaking right between the water pump and thermostat...
  15. Gen1 1.8L
    I have changed the thermostat 3 times. I still get p0597. Finally figured out that I’m not getting any ground from the blue wire that connects to the thermostat. So I rigged it so it grounds to the engine. Now the heater works but still get the code and sometimes it try’s to over heat but the...
  16. Gen1 Powertrain
    Just got my 2016 limited ls back from the shop after over a month. Ended up swapping the entire engine to get rid of P0011 code. New issue is the engine not warming up. Drove 40 miles home from work and the gauge never moved off of the lowest temperature. Check coolant and everything and notice...
  17. General Discussion
    I have a 2012 Cruze. 2 days ago my upper radiator hose exploded. I changed the hose, and added coolant. I drove it to the grocery 1/2 a mile from my house. It started getting warm, then said it was over heated, then the temp went back down to normal. I was just driving it down the highway it...
  18. Gen1 Service Issues
    Hello. 2011 Cruze 170k km Gas Codes: P0171, P0299 21,000$ rebuild at 140k km due to deer hitting it Just bought it cheap. Looking for reasons as to why my cooling fan is dead. Fuses seem good? Ones corroded slightly but good internally. Not equipped to check relays. Fan spins freely by...
  19. Gen1 Service Issues
    Hey Cruze Fam , I need some suggestions. I recently purchased a used 2011 Cruze lt from a small dealership, everything checked out, clean car fax, two owners, low mileage, excellent Condition, great price. Well I only had the car for 3 weeks and I got the “AC off due to high engine temp” so I...
  20. Gen1 1.4L Turbo
    Hi everyone, I have a 2014 Chevy Cruze LTZ 1.4L Turbo with 150,000 miles (yes I drive A LOT) and until recently little to no problems Have always kept up with maintenance and oil changes. At around 140,000 miles I started hearing the radiator fan roaring like a jet engine and would only run...
1-20 of 78 Results
Top