Chevrolet Cruze Forums banner

thermostat

  1. Gen1 1.4L Turbo
    So I finished a head job recently on my cruze and I have hopped through a bunch of hurdles as is, but now it overheats! the coolant boils over into the revisor tank and overflows... great! First thought of course is that I messed up the head gasket, but I got a new head, felpro gasket, new...
  2. Gen1 1.4L Turbo
    What’s up hey I’m a new member to the site my wife has a 2015 LTZ 1.4 turbo and all was good after we got it back from dealership after about a month the temp gauge stops working well thus being in winter I was using the heat so no need for a/c then on the dash it issued the “a/c off due to...
  3. Gen1 Service Issues
    Hi all, So I've read few articles on the above mentioned error and attempted a few fixes. So please bear with me and don't think this is just another repeat post. I've attempted a number of fixes already. In short, my wife's 2012 cruze (1.4L) was throwing the above error. My reader called it...
  4. Gen1 Service Issues
    I have a CEL for po128 and have wondered whether i need to replace a thermostat or coolant temperature sensor. I originally thought i would need a new thermostat although the heater in the vehicle is working just fine. The only thing that I have noticed is the coolant temperature gauge has not...
  5. Cruze Owner Projects
    Hello, I'm having an issue with my 2011 1.4, Im showing codes P0102, 113, 0B7, and P07E8.... I've changed the valve cover twice. Tapped and Re tapped the second time to get a tighter seal,( Rtv is absofu**inglutely pasted on this thing everywhere) compliments of shear anger at the project. MAF...
  6. Gen1 Service Issues
    Last week I noticed that my 2014 1.4L was leaking coolant from what appeared to be the thermostat housing (ended up being cracked). This solved the majority of the problem but there is still a slight leak. See the imagine below, It is now leaking right between the water pump and thermostat...
  7. Gen1 1.8L
    I have changed the thermostat 3 times. I still get p0597. Finally figured out that I’m not getting any ground from the blue wire that connects to the thermostat. So I rigged it so it grounds to the engine. Now the heater works but still get the code and sometimes it try’s to over heat but the...
  8. Gen1 Powertrain
    Just got my 2016 limited ls back from the shop after over a month. Ended up swapping the entire engine to get rid of P0011 code. New issue is the engine not warming up. Drove 40 miles home from work and the gauge never moved off of the lowest temperature. Check coolant and everything and notice...
  9. General Discussion
    I have a 2012 Cruze. 2 days ago my upper radiator hose exploded. I changed the hose, and added coolant. I drove it to the grocery 1/2 a mile from my house. It started getting warm, then said it was over heated, then the temp went back down to normal. I was just driving it down the highway it...
  10. Gen1 Service Issues
    Hello. 2011 Cruze 170k km Gas Codes: P0171, P0299 21,000$ rebuild at 140k km due to deer hitting it Just bought it cheap. Looking for reasons as to why my cooling fan is dead. Fuses seem good? Ones corroded slightly but good internally. Not equipped to check relays. Fan spins freely by...
  11. Gen1 Service Issues
    Hey Cruze Fam , I need some suggestions. I recently purchased a used 2011 Cruze lt from a small dealership, everything checked out, clean car fax, two owners, low mileage, excellent Condition, great price. Well I only had the car for 3 weeks and I got the “AC off due to high engine temp” so I...
  12. Gen1 1.4L Turbo
    Hi everyone, I have a 2014 Chevy Cruze LTZ 1.4L Turbo with 150,000 miles (yes I drive A LOT) and until recently little to no problems Have always kept up with maintenance and oil changes. At around 140,000 miles I started hearing the radiator fan roaring like a jet engine and would only run...
  13. Gen1 Powertrain
    Hi, I’m going to try and not make a long post. But I do want to pick other people’s minds. It seems like this car a 2012 which is 6 yrs old now and has 115k miles on it is having so many problems. I want to start by saying the service theft something light has came on to service it. Really weird...
  14. General Discussion
    Let me start off with saying I will not be purchasing nor recommending a Cruze ever again. When I bought my Cruze back in 2014, I should've done research but I was young & dumb and only cared about how "cool" it looked and how excited I was to show off my new car to all of my friends... if I...
  15. Gen1 1.4L Turbo
    Is it necessary to drain the coolant before replacing the thermostat housing? Will it dump a lot of coolant if I don't? Have a 2015 with the 1.4l turbo and a check engine code for P0599 "Thermostat Heater Control Circuit High". No other symptoms or leaks evident. Thanks for your help.
  16. Gen1 Powertrain
    2011 cruze a/c turns off due to engine temp warning, then temp guage pegs max temp instantly?
  17. Gen1 Service Issues
    I have a 2011 Chevy cruze 1.8l with about 220k miles and this thing has been a massive headache. Nothing but constant issues. Now, I have replaced the Water pump, thermostat and I have flushed the radiator. Still I get no heat and the fan turns on instantly on start up if it’s cold, it will turn...
  18. Gen1 1.8L
    Hello. I was lucky to have had it under warranty back then but now they want $450 to replace the same piece.. what do i do. They said code read thermostat heater circuit / open. DO the parts themselves have a warranty from GM?? nevermind they called me back it's actually covered yes!!!
  19. Gen1 Service Issues
    2011 Cruze 1.8 LS Just replaced the thermostat housing. Put it back together and have a coolant leak at the 90 degree elbow that plugs into the top stem. Upon examination, part of the old 90 degree elbow and the o-ring were broken off in the old housing. Having a hard time to find a diagram...
  20. Gen1 1.8L
    Hey everyone, I’ve recently changed my thermostat and housing on my 1.8l Cruze but it is currently leaking from the top hose that runs from the housing to the other side of the car behind the engine, I believe it is some kind of vacuum hose? I know it is broken at the piece that plugs into...
Top