Chevrolet Cruze Forums banner
tired
1-6 of 6 Results
  1. Gen1 1.4L Turbo
    This car was suich a nice car during the first 40k miles, after that there has been to many problems. from oil cooler leaks, two cam covers, two coil packs etc etc. my latest issue is that the car had a rough idle and no power, mpg suffered. checked the intake and my pcv inside was missing. i...
  2. General Discussion
    My car has been in the shop for 2 weeks in the past month. First for a slipping transmission and having the 2/6 clutch replaced, then the water pump failed, "cross hose connector" failed, and some random other things that needed replacing when the water pump failed, so needless to say going out...
  3. Gen1 Service Issues
    Hello to all,I havn't been on in a while,not much spare time. But I figured I would come vent. This cruze has had its share of problems over the almost three years I have owned it. Now another one,and I'm sick of it,but its not worth a **** to trade in and the shop can never seem to fix it...
  4. General Discussion
    Driving home tonight and this happened. Took these pictures when I got home. 25min drive.
  5. General Discussion
    Hello all, Im having a hard time dealing with all the issues im having with my 2013 LT. First I notice the insulation is coming out from under my dash at the windshield. Then the rubber seal around the touch screen started coming out and the touch system is randomly locking up to where I...
  6. CruzeTalk New Member Introductions
    Got tired of creeping around on the forum and figured I would just sign up! I have a 2011 Cruze LTZ w/RS package & Nav Ive had the car since the end of march and have racked up over 25,000 km on it already. Its been a great car for the most part! Only mod so far would be tint. 50% fronts 5%...
1-6 of 6 Results
Top