Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi All.

I am posting this from the UK as I am in need of some expert advice and there is no better place to come too than this forum.

I have a 2013 Vauxhall Zafira with a 1.4L Turbo A14Net engine and I am having some issues with it. The vehicle has been well maintained and serviced within GM / Vauxhall recommendations by the dealer themselves and the vehicle has done 155 000 miles.

A couple of weeks ago the vehicle started to run-on or dieseling. Not sure if you use the same term in the USA, but when you turn the ignition off the vehicle will continue to run for a few seconds and then stop in a rough and noisy manner. This is intermittent and seems to only do it if you run the engine for a few minutes before switching off. Whilst this intermittent running on issue was happening, the head gasket blew and this was fixed by an independent garage. Prior to that I had the oil cooler replaced by the same independent garage.

My questions is what would cause the intermittent run-on or dieseling? The independent garage has read the codes and says its coming up with under boost pressure errors. They have checked the turbo and say its fine. they suspect it could be the inlet manifold or the PCV valve. Do I need to replace the inlet manifold?

Has anyone else encountered these issue on this engine and what was the fix?

Thanks

Rob
 

·
Registered
Joined
·
47 Posts
typically - run-on or dieseling happens when a car runs rich (to much fuel) and the fuel collects on carbon deposits on the valves or piston tops.

id have the fuel trims checked and have an upper cylinder treatment done to remove carbon build up - maybe run a higher octane gas, and run seafoam in the gas for the next few fill ups

check the plugs for carbon fouling as well - maybe replace them
 
1 - 2 of 2 Posts
Top