Chevrolet Cruze Forums banner
21 - 40 of 48 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter · #21 ·
i purchased everything shown off the glowshift website and the zzp dual pillar gauge trim is nice but it is a little short my buddy has it on his cruze
 

·
Registered
Joined
·
57 Posts
I can take pictures with my cell phone and I know how to text and e mail pics but how do I get pictures on this web sight
 

·
Premium Member
Joined
·
4,646 Posts
Get the pics on your PC somehow and then use the "Insert Image" icon when typing your post. It's 4th from the right, circled in red:

page.JPG
 

·
Registered
Joined
·
158 Posts
Discussion Starter · #28 ·
one more thing since i don't know how to edit my thread now. The place where i tapped for boost is convenient but oil will flow down the line which could result in a swollen line that could blow off under boost. I would recommend checking it from time to time and possibly even replacing it or keep a small piece of line and line to line adapter in the car in case it blows off on a long trip.
 

·
Registered
Joined
·
3 Posts
I have a newsouth boost gauge from my volkswagen jetta and it only has a power and ground wire how should I go about hooking this up?
 

·
Registered
Joined
·
77 Posts
Which mount from glowshift did you get? Bc I'm still waiting to install mine

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
19 Posts
I'm not sure what happened with mine.. I hooked it all up, first it killed my battery and i still have never seen it turned on.. followed the instructions step by step, used right fuses, paid 6$ for each piece to connect the wiring safely and still nothing.. D:
 

·
Registered
Joined
·
19 Posts
No pics for now it's freezing outside. It's the boost gauge that he shared a link to on this post. The 7 color boost gauge, I used the "add a circuit" for the wiring and fuses and grounded it to a bolt by the steering column.
 

·
Registered
Joined
·
625 Posts
I would say triple check your wiring. I don't really think it would pull enough to kill the batt unless left for a few days atleast without driving it. I personally shy away from glowshift. Installed in both my buddy's truck and my car 3 pillar with coolant, bat and narrow band afr gauge. Withing 6 months they were all dead or acting up. Glowshift wouldn't do anything for me... back to your issue lol. Still check the wires. If the gauge doesn't come on with the key maybe try switching wires for a sec and hit the key. If not check your ground and if all wires check out try holding the button on the gauge with the key on. If nothing call glowshift. Hope that helps. Sorry your having probs
 

·
Registered
Joined
·
19 Posts
Yeah I was working on this dam thing for literally hours. But yeah my battery did end up having to call my friend to jump start it. I did contact them, haven't had a response yet. It's only four wires, a vacuum line and that's it. It also put me in security lockout mode D: idk, thanks for the help though haha. I'll give it a while before I try it again
 

·
Registered
Joined
·
11 Posts
Vacuum line

So.... I looked for that **** green and black wire forever!! Lol. Needless to say... it's not on the new 2016 Cruze. It's now a hard plastic line that runs into the back of the intake
 
21 - 40 of 48 Posts
Top