Chevrolet Cruze Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Trying to find out why the 12v plugs on the Cruze won't "Fast Charge" my phones with an Anker Quick Charge 3.0 USB charger plugged in. I have 3 if these chargers and all work fine in my truck and will Fast Charge our phones. But when plugged into either of the Cruze 12v outlets I am only getting slow charging.
 

·
Premium Member
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
507 Posts
That's because the 12V chargers in the Cruze don't transfer enough electricity for fast charging.
 

·
Premium Member
2013 Cruze LT
Joined
·
1,553 Posts
How are you plugging in a USB charger?
 

·
Premium Member
Joined
·
1,517 Posts
USB charging is a mess. Be amazed it charges at all.

The Chevy USB ports use Apple Charging. Probably 1A.
 

·
Premium Member
2013 Cruze LT
Joined
·
1,553 Posts
Most GM output a max of 15amps from the cig lighter. No more.
USB charging is a mess. Be amazed it charges at all.

The Chevy USB ports use Apple Charging. Probably 1A.
Again, OP is using a cigarette plug adapter, not the built in USB.
 

·
Premium Member
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
507 Posts
Do you have any literature to prove this or give specs for the 12v plugs?
No. The only way I've gotten anything to fast charge is to use a fast charging adapter in a 110/120V outlet. I figured that the 12V outlets in most vehicles weren't capable of fast charging.
 

·
Premium Member
Joined
·
1,517 Posts
Most GM output a max of 15amps from the cig lighter. No more.


Again, OP is using a cigarette plug adapter, not the built in USB.
Ugh fine.

Assuming there is nothing wrong with the charger... It’s inductive effects on the 2 data lines. Probably something to do with the design of the outlet on the Cruze combined with the design of the Anker charger.

To fix it? I have no idea. You can try a different brand which is maybe more insulated. Or an extension thing maybe.
 

·
Registered
2012 Cruze Eco 6 Speed
Joined
·
370 Posts
Ive had problums also. My phone would be plugged in and says its charging but does not charge and the battery percentage goes down ?
 

·
Premium Member
2013 Cruze LT
Joined
·
1,553 Posts
Ive had problums also. My phone would be plugged in and says its charging but does not charge and the battery percentage goes down ?
Same if I use the USB port in the center console, if I use an adapter like OP is, I get a slow but steady charge. Definitely no Quick Charge.
 
  • Like
Reactions: Diamond193

·
Registered
Joined
·
13 Posts
Discussion Starter #17
No. The only way I've gotten anything to fast charge is to use a fast charging adapter in a 110/120V outlet. I figured that the 12V outlets in most vehicles weren't capable of fast charging.
Works fine in my 08 F150
 

·
Premium Member
2015 Chevrolet Cruze LT 1.4L Turbo
Joined
·
507 Posts
  • Like
Reactions: Booger

·
Registered
Joined
·
2,846 Posts
Everytime i have your problem. And it's always the same problem. Time for a new cable.

Have you tried a different cable to see if new might be defective? Maybe the plug also.
 
1 - 20 of 30 Posts
Top