Chevrolet Cruze Forums banner

2009 Holden Cruze 2.0L Diesel - Surging/Wont Start

1280 Views 1 Reply 2 Participants Last post by  grs1961
Hi, recently my Holden Cruze (2.0L TD Manual) has been having issues starting. This happens at random. You turn the key, and you hear a clicking noise, but no wind over. If you keep trying, eventually it starts. I have replaced battery with a heavy duty battery suited to the car, I’ve also ordered a starter motor as we suspected a starter solenoid issue. We are yet to receive that part and fit it to the car.

Sometimes when you drive the engine surges and drops back acceleration a couple times and then returns to normal.

This morning, the car was idling for roughly 10 mins, and the reves started to surge up and down and the engine light began flicking on and off. When the car was driven home, it stopped doing all this and drove fine.

Any ideas? PCV Valve? MAF sensor?
1 - 2 of 2 Posts

· Registered
Joined
·
1,018 Posts
Take it to a decent mechanic, who understands small turbo-diesels, and have it diagnosed properly.

While it could be any of the items you have suggested - add negative battery cable to the list - just changing them because they may be at fault isn't a good idea.

I'd suggest Matt in Werribee if you're on that side of Melbourne, but then, you may not even be in Victoria! :)

Oh, and what does "TB" mean? AFAIK the JG Cruze came in CD and CDX trim levels.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top