Chevrolet Cruze Forums banner

2011 Chevy Cruze LS 6 Speed Manual Whistling When Accelerating

488 Views 4 Replies 3 Participants Last post by  Bearrjones1984
My 2011 Chevy Cruze 6 speed is making a whistling noise, at least that's the closest thing I can come up with regarding the sound. It sounds like blowing a whistle without the ball inside. It happens upon acceleration and when accelerating it gets higher in pitch and once it reaches 60+mph the sound stops. Any ideas?
1 - 5 of 5 Posts

· Administrator, Resident Tater Salad
Joined
·
17,879 Posts
Both issues (this and shutting off with AC on) sound like your PCV disc in the valve cover has ruptured.

You DO NOT need one of the PCV fix kits the 1.4T cars do, but the diaphragm built into the valve cover just needs to be replaced.

Usually accompanied by a P0171, P1101, occasional P0106, and whistling/honking noise from the top of the valve cover.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Both issues (this and shutting off with AC on) sound like your PCV disc in the valve cover has ruptured.

You DO NOT need one of the PCV fix kits the 1.4T cars do, but the diaphragm built into the valve cover just needs to be replaced.

Usually accompanied by a P0171, P1101, occasional P0106, and whistling/honking noise from the top of the valve cover.

This is the noise its making.

 

· Administrator, Resident Tater Salad
Joined
·
17,879 Posts
That...sounds terrible. More going on there than just this.

I hear a distinct vacuum leak though.

Scan the codes and check for obvious vacuum hose leaks or see if the noise is coming from the spark plug cover area.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top