Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So as the title states, I have a 2011 Chevy Cruze 1.4t automatic. It just rolled 105k miles so I'm just out of the warranty. Ive been having issues with the trans seeming to slip in higher gears for the past week but I dont always drive the vehicle as its not my daily. I went to back out of my apartment parking spot this morning, threw it in reverse and it just free reved and rolled forward on me. I knew something had to be going on so I pushed it far enough back to get out of my parking spot and be on my way. The forward gears seemed to work fine in town on my way to work until I had to get above 40-45 mph. It then seemed to just slip and free rev whenever in those gears. I tried putting it in autostick mode and got the same results. I work at a dealership so I got it in right away and had the techs check the fluid level while it was at proper temp. It was way over full. The last the car was in for service was at 99k for a torque converter seal at a local Chevy dealer.

WHAT HAPPENED? WHAT DO I DO?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Like stated above, I do work at a dealership in the parts department and of course automatically I'm thinking the trans is completely out and Ill need a new one. I hop on car-part and find the trans are coming up different for 2011 and 2012 etc. etc. and the pricing is all over the board. If it comes down to me having to put a trans in myself, could I get away with a trans out of a 2012 for my 2011???? Obviously the module will need to be programmed via a scanner.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top