Chevrolet Cruze Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello,

I have a 2011 eco with 126k miles. I run Amsoil SS at a interval of about 15k. I change my oil filter at 7,500k. I just had my tranny flushed using Amsoil SS ATF fuel efficient.

I went on a road trip and during the trip while checking under the hood like always do when I fill up (just checking coolant level, oil etc) and noticed this. I did have oil by the turbo feed line and on the camshaft position actuator solenoid valve. And thank you to Xtreme's "How to's" I will be changing those out this weekend. My concern right now is what in the world is causing this oil to seep out in the pics? Any direction would be helpful.

I try to take care of my Eco and stay on top of PM.
 

Attachments

·
Registered
Joined
·
122 Posts
Not to state the obvious, but is it just the valve cover / gasket?

Also, looks like there's there's a chance that oil leaking from the cam position actuator selinoid could follow that seam down the valve cover.

Sent from my XT1575 using Tapatalk
 

·
Super Moderator
Joined
·
6,632 Posts
Hello,

I have a 2011 eco with 126k miles. I run Amsoil SS at a interval of about 15k. I change my oil filter at 7,500k. I just had my tranny flushed using Amsoil SS ATF fuel efficient.

I went on a road trip and during the trip while checking under the hood like always do when I fill up (just checking coolant level, oil etc) and noticed this. I did have oil by the turbo feed line and on the camshaft position actuator solenoid valve. And thank you to Xtreme's "How to's" I will be changing those out this weekend. My concern right now is what in the world is causing this oil to seep out in the pics? Any direction would be helpful.

I try to take care of my Eco and stay on top of PM.
Welcome Aboard! :welcome:


If you are near Suzie's Dogs and Drafts, 1393 Boardman-Canfield Rd, Boardman, OH 44512, we are going there in about two hours including Andrei. Otherwise you can find us at Quaker City Motorsports Park, 10225 W South Range Rd, Salem, OH 44460 a few hours later. Somebody there should be able to help. At least 50 of us at the moment.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
I did have some carbon deposits in the 2 long ports that feed into the valve cover. Is that of a concern?
 
1 - 5 of 5 Posts
Top