Chevrolet Cruze Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,

A few weeks ago I connected jumper cables on the wrong terminals in a rush to get to work (don’t crucify me, I feel ignorant enough). After I got my car started, I noticed that 1. The car chimes do not work. 2. The display has artifacting lines going across the screen. And 3. The radio does not work. I can navigate on the display and go into the car settings. It will scroll to different radio stations and recognize that my phone is plugged up. The volume is stuck at 50 on the display. But there is no sound at all.
I’ve read on this site that the chimes are controlled by the radio.
My main question is
Do I need to replace the display, the radio, or both?

Thanks in advance.
 

·
Premium Member
Joined
·
5,535 Posts
Hello all,

A few weeks ago I connected jumper cables on the wrong terminals in a rush to get to work (don’t crucify me, I feel ignorant enough). After I got my car started, I noticed that 1. The car chimes do not work. 2. The display has artifacting lines going across the screen. And 3. The radio does not work. I can navigate on the display and go into the car settings. It will scroll to different radio stations and recognize that my phone is plugged up. The volume is stuck at 50 on the display. But there is no sound at all.
I’ve read on this site that the chimes are controlled by the radio.
My main question is
Do I need to replace the display, the radio, or both?

Thanks in advance.
Try this.....a reboot of sorts.

1. key on (not running) and radio on (should display something when on) with door open. Do not have your phone plugged into the car.
2. remove negative battery cable.......leave it in this condition for several minutes.
3. key to off (note, the key will not go to the lock position until battery power is restored.....don't freak out).
4. reconnect negative terminal.
5. start engine, let it idle for a minute or two and then try the affected accessories.

If normal operation returns you did not harm anything.......and you were lucky.....you won't make that error again.

If nothing changes, you blew its brains out and yes, the door chime is produced in the radio and sound directed to the left front door speaker.
If that is the case, I would go for the receiver first.

Rob
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Try this.....a reboot of sorts.

1. key on (not running) and radio on (should display something when on) with door open. Do not have your phone plugged into the car.
2. remove negative battery cable.......leave it in this condition for several minutes.
3. key to off (note, the key will not go to the lock position until battery power is restored.....don't freak out).
4. reconnect negative terminal.
5. start engine, let it idle for a minute or two and then try the affected accessories.

If normal operation returns you did not harm anything.......and you were lucky.....you won't make that error again.

If nothing changes, you blew its brains out and yes, the door chime is produced in the radio and sound directed to the left front door speaker.
If that is the case, I would go for the receiver first.

Rob
No luck :(
when you say "receiver" are you speaking of the display or the radio unit?
 

·
Premium Member
Joined
·
5,535 Posts
The radio is considered the receiver........BTW, you can make a insurance claim out of this if your comprehensive deductable is low enough to make it worthwhile.
Comprehensive covers the weird stuff....broken windshields, dropped my ladder on my hood, hit the fender with the lawn tractor.......shorted out my car, ahem.

Something to consider, but you do have to tell the ins. co. what happened.....no BS allowed.

Rob
 

·
Premium Member
Joined
·
8,003 Posts
The display has artifacting lines going across the screen.
The display may have problems as well, but you've clearly got problems with the main unit, sometimes called a "silver box". It sits just behind the radio buttons. If you still have lines in the display after changing that, then you'll also need to replace the display.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
The display may have problems as well, but you've clearly got problems with the main unit, sometimes called a "silver box". It sits just behind the radio buttons. If you still have lines in the display after changing that, then you'll also need to replace the display.
Thanks, at this point i'm considering buying an aftermarket head unit and replacing the display if need be.
I'm at the point where when me and my dad get my '79 Trans Am completed, i will shy away from modern cars :}
 

·
Registered
Joined
·
2 Posts
Hello all,

A few weeks ago I connected jumper cables on the wrong terminals in a rush to get to work (don’t crucify me, I feel ignorant enough). After I got my car started, I noticed that 1. The car chimes do not work. 2. The display has artifacting lines going across the screen. And 3. The radio does not work. I can navigate on the display and go into the car settings. It will scroll to different radio stations and recognize that my phone is plugged up. The volume is stuck at 50 on the display. But there is no sound at all.
I’ve read on this site that the chimes are controlled by the radio.
My main question is
Do I need to replace the display, the radio, or both?

Thanks in advance.
 
1 - 8 of 8 Posts
Top