Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey folks, the title of this post says it all. What happened was i was driving on the interstate heading home, and some idiot in a F-150 ran over a semi tire and it flew up in the air and landed on the right side of the hood of my car. When it finally fell off my hood, it went underneath the front end of the cart. It didn't bust the headlamp assembly, barely made any scratches and didn't break the bulb either (very lucky I guess). Problem is, since then my right side turn signal doesnt work and the dashboard goes nuts everytime I turn it on. The marker lights work, the bulb lights up on lock/unlock and when you auto-start, but not the turn signal. I talked to a buddy of mine and he said to take it to a garage but i'd rather not and save money if I can. I'm not an electrical guy, and don't know the first thing about it so thats why I'm posting on here. Thanks in advance if you have any ideas what it could be.
 

·
Premium Member
Joined
·
5,535 Posts
The bulb has two filaments.......one for parking/running lamp, one for signal.....signal filament is much brighter.

With lights turned off (turn headlight switch to left after startup) turn on the 4 way flashers.......most likely, the right front will do nothing.
If this is the case, just replace the bulb....odds are the vibration from the strike broke the high output filament on the old bulb.

Rob
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
That fixed it. Thanks sir. The bulb would have been the last thing I checked since the marker lights were working. I had no clue they had 2 filaments in em...we're rocking now. Much appreciated
 
1 - 3 of 3 Posts
Top