Chevrolet Cruze Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone, looking for some help lol. My car had a check engine light( the turbo underboost code) apparently a common issue with cruzes. After doing some research I found out that my pcv valve(in the intake manifold and another common issue) was gone and the pcv diaphragm on the valve cover was bad too. I replaced the intake manifold, the valve cover and pcv hose with the OE fix kit from Dorman. The repair went well and did clear all of my engine codes. The car runs fine now with no engine codes but just not quite as smooth as it used to before the issues. I checked all my vacuum lines and they all look good. I take off the oil cap or the dipstick and the engine starts to stumble. I feel like I have too much vacuum in the crankcase. Is there something I'm missing?? I replaced the entire pcv system(that I know of) and don't hear any vacuum leaks. My STFT is in the negative and my LTFT is just barely in the positive. Any help would be appreciated. Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Hey everyone, looking for some help lol. My car had a check engine light( the turbo underboost code) apparently a common issue with cruzes. After doing some research I found out that my pcv valve(in the intake manifold and another common issue) was gone and the pcv diaphragm on the valve cover was bad too. I replaced the intake manifold, the valve cover and pcv hose with the OE fix kit from Dorman. The repair went well and did clear all of my engine codes. The car runs fine now with no engine codes but just not quite as smooth as it used to before the issues. I checked all my vacuum lines and they all look good. I take off the oil cap or the dipstick and the engine starts to stumble. I feel like I have too much vacuum in the crankcase. Is there something I'm missing?? I replaced the entire pcv system(that I know of) and don't hear any vacuum leaks. My STFT is in the negative and my LTFT is just barely in the positive. Any help would be appreciated. Thanks
Left this out sorry. Its a 2012 1.4L Chevrolet Cruze LT with 140,000 miles
 
1 - 2 of 2 Posts
Top