Chevrolet Cruze Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
So I've lurked around for about a month trying to find an answer or similar thread and have been unsuccessful. I apologize if this should be posted elsewhere. Original owner of 2012 Cruze 55K miles. Last month I was letting my car warm up and went out to shut it off after 15 minutes because I had to attend a spontaneous meeting. When I came back out the car wouldn't start and showed "check power steering " warning. The only noise it made when attempting to start was a slow "tick....tick....tick" not the typical dead battery tick tick tick tick. So I attempted to jump with a jump box and then tried to charge it. Yes, the cables were properly attached.. call tow truck out and the guy wants to try and jump it so I let him and bang it starts right up. Problem is that ever since my dash lights don't work. Needle gauges work fine but low gas warning light is on constantly even when full. Digital speedometer doesn't work and there are no back lights so driving at night is a guessing game on speed and all other gauges. During start up all warning lights come on but go off after vehicle is started. Checked negative cable connection and appears to be no issues. Radio/Hvac lights work fine and I have had no startup issues since and no other power issues. Any ideas? All fuses check out fine. Thanks in advance
 

·
Registered
Joined
·
232 Posts
Sounds like you need to replace the battery. The time it's disconnected to replace it will most likely reset the rest of the systems. (however, if someone more experienced with this thinks otherwise, I'll happily defer to them)
 

·
Premium Member
Joined
·
8,003 Posts
You've got two problems: a car that wouldn't start, and a confused BCM. Disconnect the battery for 10 minutes or so should solve the confused BCM issue.

As for the starting issue, it could be a battery on it's way out, or a bad battery ground cable. It's a coin toss on which is more likely.
 

·
Registered
Joined
·
97 Posts
had a issue like this and your fix did the job on my wifes Cruze.. Works good and she still has the same battery. She bought hers Dec 27 2011. I think she is due for a new battery,that has just under 12,000 miles.
 

·
Registered
Joined
·
251 Posts
There's a similar discussion in the GM-Trucks forum. If you do not connect the negative post LAST, it throws the BCM into "a heart-attack," causing all kinds of electrical issues.

I've also seen where the dash lights did not work, and it was cause there was a tail light out, or all of the tail lights were out. My '91 Nissan King Cab, when I had it.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top