Chevrolet Cruze Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hey there,

Been reading a lot of this forum and figured I'd get an opinion or two before I tear into my wife's car this weekend given my inexperience - I'm decently handy, but haven't gone this deep on an engine before.

The short version is I've got a loud engine ticking that sounds like this:

And a P0324 CEL code from my Bluetooth scan tool. ~65k miles on the engine, no warranty left. Seems like the power is lower too, my assumption was the CEL was throwing the engine into some kind of limp mode though.

Both of the symptoms (ticking and CEL) were intermittent, but have been more persistent lately. Here's what's been "diagnosed"/tried so far:
  • First shop to tried a fuel injector service to fix the problem, seemed to work at first but CEL came back
  • First shop suggested then said spark plugs "might help," but seemed like they were just guessing... now I get why
  • Dealer first said "bad gas," see if CEL goes off after a full tank
  • CEL stays on, 30 days later dealer says "major engine issue" and they could take it apart but "weren't sure if they could get it back together" (seriously?)
So here I am!

Based on some searching I believe it could be:
There also seems to be a bit of an oil leak somewhere, I see a small bit of it pooled around some areas, and my wife mentioned she smelled some burning once or twice a few months ago, and the last time I had the oil changed at the dealer (maybe a year ago?) the tech showed me oil residue on the pan while it was up on the lift. Level reads normal on the dipstick after ~5,000 after the last change, though, so doesn't seem like a major issue? Haven't noticed any drips under the car, ever.

Anyway, my plan is roughly this:
  • Ensure PCV check valve exists. If not, perform PCV fix.
  • Check for loose spark plugs, tighten if necessary.
  • Open valve cover and check for a loose timing chain guide. Torque to spec if loose.
  • See if I can see anything obvious once the valve cover's off. I doubt it, but I'll take pictures at least.
I have a few questions:
  • Should I replace the spark plugs while I've got everything open? Manual doesn't call for them until 100k but they're original, and it's what the original shop was going to do next.
  • If I take off the valve cover and put it back on, do I need to put on a new layer of sealant? If so, what's recommended?
  • Should I replace the valve cover while I'm removing it anyway, and potentially extend the time before I (or the next owner) have to deal with the PCV assuming it's intact? And perhaps help with the oil leak?
  • Anything else I should consider as a part of my plan?
It seems like this car is falling apart. Beyond the above, the thermostat had to be replaced 2 months ago, and a couple of weeks ago the horn started sounding funny and eventually blew a 15A fuse. Planning to replace that once I have a reason to drive by the auto parts store... but having all these parts fail at the same time is really making me question my sanity.

Thanks for your time.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
Thanks for the pointer. Anything, in particular, make you think that might be the issue? Just asking because I haven't seen those be a common problem, but it's very possible I missed something.

Also took a few pics of where I saw what I think is oil pooled and maybe one possible spot it's leaking from...

IMG_20200203_222650.jpg IMG_20200203_222715.jpg IMG_20200203_222730.jpg IMG_20200203_222803.jpg
 

·
Registered
Joined
·
6 Posts
I've heard that sound before at the shop I work at. We changed the silnods due to a check engine light (don't remember the code)but changing them did make the noise go away. They are not to expensive and are easy to change

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
203 Posts
The video shows the purge valve ticking
ACDelco 55573017
This is a 10 minute R&R
I would pull the plugs and evaluate if they need changing or not
If the valve cover isn't "whistling" there is no need to change it
I would remove and reapply the sealant on the valve cover, the gasket will be ok to reuse

Keep us updated
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
The video shows the purge valve ticking
ACDelco 55573017
This is a 10 minute R&R
I would pull the plugs and evaluate if they need changing or not
If the valve cover isn't "whistling" there is no need to change it
I would remove and reapply the sealant on the valve cover, the gasket will be ok to reuse

Keep us updated
Holy moly, I think you're right that it's the purge valve making the higher-pitched noise. Stuck my ear by it and it's definitely coming from further back than the engine block.

Ordered the replacement and will keep you updated - worst case it goes back to Amazon with free returns.

Thanks again for the details and time.
 

·
Registered
Joined
·
203 Posts
The p0324
Check your charge pipes for oil. Oil will reduce the octane of the fuel and may cause knocking.

I installed a catch-can to alleviate this issue
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Not a great start to this project... replaced the purge valve and the ticking continues. Went to verify the check valve in the PCV system and while doing so accidentally snapped the **** hose, so going to perform this mod: Corrugated PCV Hose Replacement/Upgrade

Going for spark plugs next...
 

·
Super Moderator
Joined
·
7,475 Posts
P0324:
Potential causes for this code to set are:

Defective knock sensor/s
Internal engine malfunction
Ignition misfire/s
Contaminated or substandard fuel
Defective knock sensor control wiring and/or connectors
Bad PCM or a PCM programing error

Read more at: P0324 Knock Control System Error


This is my running click, tick and rattle list:

1. Could be just the injectors

2. Could be the plastic ECOTEC cover rattling

3. Check that the spark plugs are properly torqued -- 18ft-lbs (might as well re-gap them - .028 for a 1.4) and make sure the springs are not stuck/bent etc.

4. Could be a failing EVAP purge solenoid/valve or possibly a vacuum leak causing the purge valve to stay open

5. Could be a lifter tick - try seafoam or valvemedic

6. Could be the timing chain tensioner

7. Could be a sloppy timing chain

8. Could be piston slap/wrist pin failure

9. Pinging caused by low octane fuel

10. Could possibly be an improperly torqued bolt on the flywheel/torque converter (noise from the trans side)

11. Might be a bad wheel bearing

12. Possibly the knock Sensor going off or bad and it can be exacerbated by any of the above.

13. Maybe your AC compressor is going bad
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12 (Edited)
Thanks for all the ideas.

I went ahead and changed the spark plugs this weekend while checking the tightness. Still sounds kinda like a diesel engine, unfortunately. Going to try running a few tanks of 93 and see if that changes anything.

For $5 I might give the oil conditioner a try next. I'm starting to doubt my timing chain guide theory because the ticking seems to be coming from the rear-right of the engine rather than the left-front-ish... so trans side I guess, but more towards the rear? Any bolts that typically come loose over there? The engine seems to be vibrating a decent amount at idle, to the point of visibly shaking the large plastic pipe on the top of the engine on that side.

Ran another scan and found I also have a P0325 code - not terribly informative, and my gut tells me the knock sensor is just doing its job rather than having an issue given the code and the ticking appeared at the same time.

edit: additional theory - loose rocker on the camshaft?
 
1 - 12 of 12 Posts
Top