Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The day I bought my 2013 Chevrolet Cruze LT RS 1.4 it lost power on the way home and it was under a certified warranty at 80,500 miles. So the dealer said they fixed it, they did not it lost power several times after was in and out of the shop a lot until it got to 100k and it wasn’t covered then I had my mechanic look at it and he said that the gas pedal and turbo needed to be replaced and that they knew that at the dealer, that there was no way that a certified mechanic could have missed it! So I had to pay to replace those myself! I did and at 140k miles I drove it for like 5 minutes and it cut off I have no clue what it could be but it won’t turn over so of course I had the battery tested and it tested good but I bought a new one anyway this was a year ago! I’ve been making $400.00 payments every month while not being able to afford to fix it but we did replace the starter and the throttle position sensor, and the gas pedal again, and tested several parts to make sure that they were all working properly but I have no clue someone said could be throttle body, is that a possibility? It’s the craziest thing it was running fine and all of the sudden when I stopped it idled down and cut off and hasn’t started a single time since! Help! Has anyone else had this happened! I’ve grown to hate Chevrolet because I’ve contacted them so many times before the warranty was up and they wouldn’t help me at all! That’s 17grand I’ll never get back and it’s not even paid off yet! Not to mention the brakes have locked up multiple times and I was told my brakes were good! I will probably never buy Chevrolet again!
 

·
Premium Member
Joined
·
5,026 Posts
$17K for a 2013 Certified Cruze with 80,500 miles on it? Fast-forward 60 thousand miles and you drove it for 5 minutes and it cut off. How long have you owned this beast?
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
7,936 Posts
The day I bought my 2013 Chevrolet Cruze LT RS 1.4 it lost power on the way home and it was under a certified warranty at 80,500 miles. So the dealer said they fixed it, they did not, it lost power several times after was in and out of the shop a lot until it got to 100k

it wasn’t covered then I had my mechanic look at it and he said that the gas pedal and turbo needed to be replaced and that they knew that at the dealer, that there was no way that a certified mechanic could have missed it! So I had to pay to replace those myself! I did it at 140k miles.

I drove it for like 5 minutes and it cut off. I have no clue what it could be but it won’t turn over, so of course, I had the battery tested and it tested good.

but I bought a new one anyway, this was a year ago! I’ve been making $400.00 payments every month while not being able to afford to fix it, but we did replace the starter and the throttle position sensor, and the gas pedal again, and tested several parts to make sure that they were all working properly.

but I have no clue, someone said it could be throttle body, is that a possibility? It’s the craziest thing, it was running fine and all of the sudden when I stopped it idled down and cut off and hasn’t started a single time since!

Help! Has anyone else had this happened! I’ve grown to hate Chevrolet because I’ve contacted them so many times before the warranty was up and they wouldn’t help me at all!

That’s 17grand I’ll never get back and it’s not even paid off yet! Not to mention the brakes have locked up multiple times and I was told my brakes were good! I will probably never buy Chevrolet again!
Welcome Aboard!(y)

2013 LT 1.4T LT
Warranty 80,500 - 100,00 - now out of warranty

1. What were the original codes, should be on the receipts?

Replaced the throttle position sensor and turbo.

2. Again, what were the codes?

Replaced battery, replaced TPS and throttle body

3. Why?

Don't forget to introduce yourself and your Cruze here.
 
1 - 3 of 3 Posts
Top