Chevrolet Cruze Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
I purchased my 2014 Cruze diesel a year ago with 28K miles on it in southern California where I live. Its been running really well and I've been a happy camper (other than finding out that the car MPH gets reduced when it needs more DEF!) A few weeks ago the CEL came on and its staying on now. After checking recalls, I chalked it up to the NOX sensor recall but the local dealer says mine had the sensor replaced last year. It's been running normally after the CEL came on until a few days ago when I filled the gas tank.... when I restarted it the display started showing the following.... "Service Exhaust Fluid System" followed by "See owners manual Now"... then followed by "90 miles until 65 MPH Max Speed". If anybody can shed some light on this I'd truly appreciate it.
 

·
Registered
Joined
·
302 Posts
My guess would be either the DEF pump needs to be replaced or the DEF tank heater needs to be replaced. Just a guess though. I've seen a few people post andsay the DEF tank heater was shot. Mine had to have the DEF tank replaced because the heater went around 40k miles.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
DEF tank replacement .... those sound like expensive repairs. Was yours covered by warranty? My Cruze is at 52K miles so no warranty... ouch!
 

·
Premium Member
Joined
·
2,217 Posts
I think there is a special warranty extension on def tank for 10 years 120k miles.
 
  • Like
Reactions: BarbS and MRO1791

·
Banned
Joined
·
260 Posts
It's been running normally after the CEL came on until a few days ago when I filled the gas tank.... when I restarted it the display started showing the following.... "Service Exhaust Fluid System" followed by "See owners manual Now"... then followed by "90 miles until 65 MPH Max Speed". If anybody can shed some light on this I'd truly appreciate it.
Just to be clear about what you mean in your statement above where you state "I filled the gas tank"?? You filled the fuel tank with diesel or you filled the DEF tank with DEF fluid. I'm just asking because we had other users fill their DEF tank with diesel fuel.... WRONG!! Do not pass go, you pay $$$$$ and you don't go anywhere!

I just recently had a similar issue where I started getting the NOX sensor 1 & 2 and poor DEF fluid CELS after adding DEF fluid from a 6 month old bottle I had stored in the trunk. I replaced the NOX 1 sensor and replaced the old DEF fluid I had put into the DEF tank, the codes cleared while driving for about 100 miles but could not get rid of the service exhaust fluid system. Then I took it in to the dealer where they checked the DEF system and DEF flow, did a manual regen and all has been good for the last 1000 miles now.

You need to read the codes to get insight into whats going on with the system.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #8 ·
Just to be clear about what you mean in your statement above where you state "I filled the gas tank"?? You filled the fuel tank with diesel or you filled the DEF tank with DEF fluid. I'm just asking because we had other users fill their DEF tank with diesel fuel.... WRONG!! Do not pass go, you pay $$$$$ and you don't go anywhere!

I just recently had a similar issue where I started getting the NOX sensor 1 & 2 and poor DEF fluid CELS after adding DEF fluid from a 6 month old bottle I had stored in the trunk. I replaced the NOX 1 sensor and replaced the old DEF fluid I had put into the DEF tank, the codes cleared while driving for about 100 miles but could not get rid of the service exhaust fluid system. Then I took it in to the dealer where they checked the DEF system and DEF flow, did a manual regen and all has been good for the last 1000 miles now.

You need to read the codes to get insight into whats going on with the system.
I had just filled the fuel tank with diesel fuel. Thats when the CEL came on and wouldnt turn off for 2 weeks... UPDATE! I took it over to the Chevy dealer for them to checkout. They had it for 4 days and never called me once... not even when it was ready for pickup. I called them and braced myself for bad news. Well it turns out the car needed a NOX 1 sensor recall done. I think they did that because the car was in shop so why not, but it wasnt the cause of the CEL. As for the CEL light and "Service Diesel Exhaust Fluid System" warning.... it was caused by a bad DEF fluid reservoir. They had to replace the DEF tank! The good thing is they covered all expenses. Total cost: $0.00. CEL is gone and a brand new DEF tank installed. Chevy made me a happy camper.
 

·
Registered
Joined
·
216 Posts
I had just filled the fuel tank with diesel fuel. Thats when the CEL came on and wouldnt turn off for 2 weeks... UPDATE! I took it over to the Chevy dealer for them to checkout. They had it for 4 days and never called me once... not even when it was ready for pickup. I called them and braced myself for bad news. Well it turns out the car needed a NOX 1 sensor recall done. I think they did that because the car was in shop so why not, but it wasnt the cause of the CEL. As for the CEL light and "Service Diesel Exhaust Fluid System" warning.... it was caused by a bad DEF fluid reservoir. They had to replace the DEF tank! The good thing is they covered all expenses. Total cost: $0.00. CEL is gone and a brand new DEF tank installed. Chevy made me a happy camper.
Great to hear ;-)
 

·
Registered
Joined
·
47 Posts
give it a couple of days. I say that because they just replaced mine and before I'm home I have a check engine light on.
-
I going to give it a 24hr cooling off period before I say any more.
 

·
Registered
Joined
·
1 Posts
I had just filled the fuel tank with diesel fuel. Thats when the CEL came on and wouldnt turn off for 2 weeks... UPDATE! I took it over to the Chevy dealer for them to checkout. They had it for 4 days and never called me once... not even when it was ready for pickup. I called them and braced myself for bad news. Well it turns out the car needed a NOX 1 sensor recall done. I think they did that because the car was in shop so why not, but it wasnt the cause of the CEL. As for the CEL light and "Service Diesel Exhaust Fluid System" warning.... it was caused by a bad DEF fluid reservoir. They had to replace the DEF tank! The good thing is they covered all expenses. Total cost: $0.00. CEL is gone and a brand new DEF tank installed. Chevy made me a happy camper.
Did they happen to mention if this was a recall or just a good faith replacement? I have a 2014 model also and just had to have the DEF tank replaced. I have read in a few forums that GM has been doing Good Faith Replacements up to 10 years 120,000 miles. My vehicle has 121,500 but the dealer is telling me there is no type of coverage anyways
 

·
Registered
Joined
·
54 Posts
Did they happen to mention if this was a recall or just a good faith replacement? I have a 2014 model also and just had to have the DEF tank replaced. I have read in a few forums that GM has been doing Good Faith Replacements up to 10 years 120,000 miles. My vehicle has 121,500 but the dealer is telling me there is no type of coverage anyways
I had the tank heater replacement done a few months ago. If you search for my username I'm sure you'll find the thread. Any dealer saying there is no extended coverage sounds like a true lying piece of ****.
 

·
Registered
Joined
·
1 Posts
Im looking to do a dpf def egr delete. Any help on getting all the info i need? Seems hard to find the right stuff to do now days.
 

·
Registered
Joined
·
533 Posts
Im looking to do a dpf def egr delete. Any help on getting all the info i need? Seems hard to find the right stuff to do now days.
If they are out there tuning and providing down pipes they are staying quiet about it. Feds are coming down hard on EPA violators as they should. Hope you have zero success.
 
  • Like
Reactions: BDCCruze

·
Registered
Joined
·
3 Posts
Same issue three years now. Blown every pump. Finally put in a pump with a warranty. Trying to find the problem with two mechanics and the dealership to no avail. Just commented to tell you you’re not alone and it’s not just one car doing this and we have the exact same problem my mom and I share a couple of cars. We can not find the issue.until my son found this site Idk that anyone else was going Thru this. So there is more than one car with this issue.
 
1 - 16 of 16 Posts
Top