Chevrolet Cruze Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Oh I need some good advice.
Purchased a 2015 Cruze used of course 2/20/17. 39339 miles. Was a rent a car.
Next day bringing car to dealership to get cleaned. Service light on and white smoke from engine coming out.
Take to service department, seal on radiator is gone and antifreeze spilled all over engine.
Next day, got a new radiator cap with seal, they reset code.
Friday 2/24/17 guess what service light is on. Catalytic converter code. Chevy replaced the converter.
ok so the next 7 days no service light on but eighth day back on. Now it's the Oxygen sensor 2.
Chevy has my car since Monday 3/6/17 the technicians are saying it's an emissions issue but can't pin point it.
Could the antifreeze been at fault?
 

·
Moderator
Joined
·
2,170 Posts
Welcome to the forum!

Sorry to hear you're having issues already with your purchase. I don't want to be that guy, but buying a former rental is not a great idea. What trim level is your Cruze? (L, LS, 1LT, 2LT, ECO, LTZ or Diesel) I'm assuming since it was a rental it was probably an LTZ auto with the 1.4L turbo. Was the smoke coming from under the hood or out of the tail pipe? Would you be able to provide the check engine trouble code numbers?

I hope you're able to get the issues solved, when the Cruze is running well, it's a really sweet car. (My cruze is so much better than the awful dodge dart rental I just returned today.)
 
  • Like
Reactions: 2015LT2

·
Administrator
Joined
·
25,596 Posts
Welcome aboard. I'd be thinking about taking it back to the seller cancelling the sale on the grounds they sold a lemon.
 
1 - 5 of 5 Posts
Top