Chevrolet Cruze Forums banner
1 - 4 of 4 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
The AC stopped last summer. I attempted to add freon but the gauge read "high pressure" and the clutch would not engage. Checked and changed all fuses still no AC. Temp sensor for outside temp is accurate. Radiator recently flushed and coolant changed. Any trouble shooting I can do?
 

· Registered
Joined
·
4,118 Posts
First off. What does high pressure mean.

If you want help. We need numbers. That's your best help.

I don't use cans so I have no idea but a wild guess would be you have too much in the system. An overcharge will prevent the compressor from kicking on.

Cars don't hold much these days. Those 12 oz. Cans will very easily overcharge the system when you only need one or two ozs. To top it off.

If not careful. You'll end up in trouble with those cans.
 

· Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
First off. What does high pressure mean.

If you want help. We need numbers. That's your best help.

I don't use cans so I have no idea but a wild guess would be you have too much in the system. An overcharge will prevent the compressor from kicking on.

Cars don't hold much these days. Those 12 oz. Cans will very easily overcharge the system when you only need one or two ozs. To top it off.

If not careful. You'll end up in trouble with those cans.
The gauge read that it was over charged but I am told that you cannot read the true pressure if the compressor is not on.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top