Chevrolet Cruze Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2018 Chevrolet cruze. I have hid headlights from the previous owner and the drivers side went out so I bought some leds to replace. The drivers side eventually completely went blank, the bulb, turn signal, and lower thin light. The entire assembly doesn't work. I'd this an electrical issue? Anyone had this?
 

·
Registered
Joined
·
1,637 Posts
If all the components of the lamp dont work it's probably a ground issue. Poor connection causing overheating, damaged terminals, damaged wiring....etc. try swapping the lamps from side to side to verify if it's the lamp wiring or car wiring without using diagnostic tools or measuring anything
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
If all the components of the lamp dont work it's probably a ground issue. Poor connection causing overheating, damaged terminals, damaged wiring....etc. try swapping the lamps from side to side to verify if it's the lamp wiring or car wiring without using diagnostic tools or measuring anything
If all the components of the lamp dont work it's probably a ground issue. Poor connection causing overheating, damaged terminals, damaged wiring....etc. try swapping the lamps from side to side to verify if it's the lamp wiring or car wiring without using diagnostic tools or measuring anything
Yea im getting my new leds Monday so I will see if ots the bulb if not I will need to find the electrical issue.
 
1 - 3 of 3 Posts
Top