Chevrolet Cruze Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello ladies and gentlemen my name is angel I recently purchased a salvage 2019 Cruze with 7k miles and today when I was driving in the freeway I ran over a piece of plastic and immediately my traction control and abs light lit up and they haven’t shut off as soon as that happened I got off the car checked for any visual damage and went under the car and everything looks perfect nothing is wrong no leaks or ripped sensors! I already drove the car 50 miles I unplugged the battery for 10 minutes and nothing changes what could it be or what can I do to erase the lights and I want to avoid going to the dealer because warranty got canceled when the car was announced totaled from my understanding.
 

·
Registered
Joined
·
799 Posts
...today when I was driving in the freeway I ran over a piece of plastic and immediately my traction control and abs light lit up and they haven’t shut off ...
Pull the front wheel off which hit the plastic. Inspect very closely the wire going to the wheel speed sensor. I'm betting it got damaged by the debris you hit. An intermittent or open connection can cause the warnings you are seeing. Trace the wire back from the wheel looking for an impact spot.

[Edit]You may need to inspect both front wires if the car straddled the debris it hit.

Doug

.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Pull the front wheel off which hit the plastic. Inspect very closely the wire going to the wheel speed sensor. I'm betting it got damaged by the debris you hit. An intermittent or open connection can cause the warnings you are seeing. Trace the wire back from the wheel looking for an impact spot.

[Edit]You may need to inspect both front wires if the car straddled the debris it hit.

Doug

.
no it’s weird everything is fine the wire is perfectly tucked inside the wheel almost impossible to de damaged and the fender liner is in perfect condition I gues the front tire just slipped while running over it I checked everything really close and nothing is bent or ripped could it just be that I need to do a reset and if so how can I do one my scanner does not read abs or traction control
 

·
Registered
Joined
·
799 Posts
no it’s weird everything is fine the wire is perfectly tucked inside the wheel almost impossible to de damaged and the fender liner is in perfect condition I gues the front tire just slipped while running over it I checked everything really close and nothing is bent or ripped could it just be that I need to do a reset and if so how can I do one my scanner does not read abs or traction control
If you hit something and the "traction control and abs light lit up and they haven’t shut off", then you encountered more than just a little wheel slip. I would keep poking around the front end looking at things.

Also, try to find a code reader that does ABS. Those are pretty common. Mine is an old Actron 9580A, and it does ABS codes. Perhaps you can get your codes scanned at the parts store with one that has that capability.

Doug

.
 

·
Super Moderator
2014 LT program car, Pull Me Over Red
Joined
·
8,429 Posts
Hello ladies and gentlemen my name is angel I recently purchased a salvage 2019 Cruze with 7k miles and today when I was driving in the freeway I ran over a piece of plastic and immediately my traction control and abs light lit up and they haven’t shut off as soon as that happened I got off the car checked for any visual damage and went under the car and everything looks perfect nothing is wrong no leaks or ripped sensors! I already drove the car 50 miles I unplugged the battery for 10 minutes and nothing changes what could it be or what can I do to erase the lights and I want to avoid going to the dealer because warranty got canceled when the car was announced totaled from my understanding.
Welcome Aboard!(y)

I would look at the wiring for the sensors. The plastic may have damaged them. EDIT- I kept reading and saw that was already given, but I agree, keep looking.

Don't forget to introduce yourself and your Cruze here.
 

·
Registered
Joined
·
26 Posts
I've had my Cruze looked at, I've looked and looked and looked at it and cannot find any damage either but my ServiceStabilitytrak/Tractioncontrol comes on every day 2 times a day at least
 
1 - 8 of 8 Posts
Top