Chevrolet Cruze Forums banner

41 - 47 of 47 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #41
Just heard from a local mechanic on the A/C issue. He said the compressor is not getting power, and on his research GM has problems with body control modules, where it could be getting the power from. He checked everything else and it was OK. He said he doesnt know what else to do with it. I would think that would be somewhat of a simple issue, but of course it never is.
One other thing I noticed was the fan not kicking on. I sat with the car parked and running for about 10 minutes in 85° heat. I opened the the hood and the fan never kicked on, with and without the A/C being on.
 

·
Registered
Joined
·
889 Posts
So from all that I gather it could be in the bcm?
I've attached a drawing for the AC under the hood. You say the compressor is not coming on when you turn the AC on. Looking at the drawing, in this case, it appears the BCM is not in the loop. So we can forget about it for now.

I would start with KR29, the AC compressor clutch relay in the underhood fuse box. It sends +12V to the compressor clutch. Or it's supposed to. If you see +12V on X3-44 coming out of the fuse box, but the clutch is not engaged, then trace the wiring to the clutch/compressor, looking for a bad connection. If you don't see +12V on X3-44, then try swapping relays to see if that helps.

If a different relay doesn't help, make sure the relay is getting power. Remove it and check the sockets for relay pins 85 and 30. Both should be at +12V (with the key on).

If the relay is getting power, check pin X3-34 into that fuse box. It controls the relay. When the compressor is (supposed to be) ON, that pin should be low, ~0v. If that pin is not low, the ECM is not turning on the compressor. That could be due to a bad refrigerant pressur sensor reading, or failure of the serial link from the HVAC control module to the ECM (altho I might expect some sort of warning of failed comm on the DIC , if that occurred).

Those are a few things to check, to try to isolate the issue. I can't go trhu every possible combination, but I'll try to help more if you can give us some feedback on these tests.

Below are the RPO's called out in the drawing. In my comments above, I have assumed you don't have any of teh 1.6L options.

Doug

L2W ENGINE-GAS, 4 CYL, 1.6L, MFI, L4, DOHC, FAM 1, GEN S200, 80 KW, E20 MAX
LXT ENGINE-GAS, 4 CYL, 1.6L, MFI, DOHC, 80KW (GMDAT)
LDE ENGINE-GAS, 4 CYL, 1.6L, MFI, DOHC, VVT, VARIABLE CAMSHAFT PHASING, VARIABLE INTAKE MODULE (VIM)

LNP ENGINE-DIESEL, 4 CYL, L4, 2.0L, CRI, DOHC, TURBO, 120 KW
LVM ENGINE-DIESEL, 4 CYL, 1.6L, CRI, DOHC, FGT, 81KW

2H0 ENGINE-GAS, 4 CYL, 1.8L, MFI, 103KW, DOHC
LFH ENGINE-GAS, 4 CYL, 1.8L, MFI, E100 MAX
LUW ENGINE-GAS, 4 CYL, 1.8L, MFI, 103KW, DOHC, E85 MAX

.
 

Attachments

·
Registered
Joined
·
37 Posts
Discussion Starter #43
I've attached a drawing for the AC under the hood. You say the compressor is not coming on when you turn the AC on. Looking at the drawing, in this case, it appears the BCM is not in the loop. So we can forget about it for now.

I would start with KR29, the AC compressor clutch relay in the underhood fuse box. It sends +12V to the compressor clutch. Or it's supposed to. If you see +12V on X3-44 coming out of the fuse box, but the clutch is not engaged, then trace the wiring to the clutch/compressor, looking for a bad connection. If you don't see +12V on X3-44, then try swapping relays to see if that helps.

If a different relay doesn't help, make sure the relay is getting power. Remove it and check the sockets for relay pins 85 and 30. Both should be at +12V (with the key on).

If the relay is getting power, check pin X3-34 into that fuse box. It controls the relay. When the compressor is (supposed to be) ON, that pin should be low, ~0v. If that pin is not low, the ECM is not turning on the compressor. That could be due to a bad refrigerant pressur sensor reading, or failure of the serial link from the HVAC control module to the ECM (altho I might expect some sort of warning of failed comm on the DIC , if that occurred).

Those are a few things to check, to try to isolate the issue. I can't go trhu every possible combination, but I'll try to help more if you can give us some feedback on these tests.

Below are the RPO's called out in the drawing. In my comments above, I have assumed you don't have any of teh 1.6L options.

Doug

L2W ENGINE-GAS, 4 CYL, 1.6L, MFI, L4, DOHC, FAM 1, GEN S200, 80 KW, E20 MAX
LXT ENGINE-GAS, 4 CYL, 1.6L, MFI, DOHC, 80KW (GMDAT)
LDE ENGINE-GAS, 4 CYL, 1.6L, MFI, DOHC, VVT, VARIABLE CAMSHAFT PHASING, VARIABLE INTAKE MODULE (VIM)

LNP ENGINE-DIESEL, 4 CYL, L4, 2.0L, CRI, DOHC, TURBO, 120 KW
LVM ENGINE-DIESEL, 4 CYL, 1.6L, CRI, DOHC, FGT, 81KW

2H0 ENGINE-GAS, 4 CYL, 1.8L, MFI, 103KW, DOHC
LFH ENGINE-GAS, 4 CYL, 1.8L, MFI, E100 MAX
LUW ENGINE-GAS, 4 CYL, 1.8L, MFI, 103KW, DOHC, E85 MAX

.
Would you mind coming up to Michigan to take a look at it? Lol. Thanks for the info.
 

·
Registered
Joined
·
889 Posts
Is KR 29 labeled as a number in the owners manual? I dont see that particular number.
Sorry about that. I meant to cross check that earlier. It should be relay #1 as shown in the pic below. That gibes with the owner's manual listing under "micro relays" following the fuse list.

FWIW, I get these drawings via my library who provides card holders with access to Chilton's on-line stuff. But the navigation sucks. Getting to the place where it says "KR29 = #1" was like finding the proverbial needle in the haystack.

If I was paying a subscription fee, I'd be screaming at their tech support. That is, I don't know if this is the same on-line documentation as what someone might purchase from Chilton's, but if it is...well, it's difficult to find what you're looking for without wading thru pages and pages of search results, sort of like web search engines before Google came along :)

Doug

2015_cruze_underhood_fuse_block.gif

.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #46
Well, finally got the word from the dealer. Compressor was bad. $1,033 installed. :cautious:
 

·
Registered
Joined
·
729 Posts
41 - 47 of 47 Posts
Top