Chevrolet Cruze Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi
I'm wondering if anybody would know how to fix this?
My Cruze keeps its ABS light on upon starting the car and as I drive, after a few meters of driving the service light comes on.
From my knowledge if the ABS light is on it cannot function while the vehicle is being driven.
I had the car checked at my local auto shop and they can't seem to reset it.
Had this since 30k km but haven't had the time to fix it.

2012 Chevrolet Cruze
5MT 1.8 Gas LS
40k km
Made in Korea

I would really appreciate your comments thank you
 

·
Premium Member
Joined
·
8,003 Posts
You'll need to find a better shop that can diagnose what's wrong with the ABS system. In a lot of cars, the usual ABS problem is a broken wire to the wheel sensor. But it could also be a bad pump. You need someone who can pull the codes and understand what's going on. It's unlikely to be a simple fix that the average owner can do.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
@ChevyGuy: Thanks for the info. this same car had a trouble code last time but it was for a check engine light, it was easily cleared last time by a relative of mine who owns a OBD Scanner. Will that same scanner work for for reading whats wrong in the service light or abs?
 

·
Administrator
Joined
·
25,596 Posts
It might.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
Sorry for the long wait
But I finally fixed this problem! thanks to BLUE DRIVER i was able to scan my car's ABS codes and with a simple clear command the light stays off!
added to that i had my abs sensors cleaned and now the car runs good!
 

·
Administrator
Joined
·
25,596 Posts
Thank you for the final resolution information on your ABS system.
 
1 - 7 of 7 Posts
Top