Chevrolet Cruze Forums banner

AC hot and cold random 2013 LT HELP!

7017 Views 6 Replies 2 Participants Last post by  Mo Cruze
Sometimes i get in the car and ac wont work for like 15 minutes then outta no where go ice in a second. Or ill be driving with cold ac for 20 minutes then boom hot for 5 minutes until i break out sweating. very frustrating as i live in florida. Ive brought it in before and they say everything checks out. Sometimes it will work great for a week then ill have a bad week where it keeps going hot. then as soon as i bring it in it will blow cold SMH..did anyone find the ultimate cause of this??? im bringing it in again today... i feel like its some kind of loose connection or something. there has been ti,es i turn the car off then back on and blow out cold instantly..Any help would be great im going to dealer today maybe something i can point out??? any help would be much appreciated
1 - 3 of 3 Posts

· Premium Member
Joined
·
24,131 Posts
This sounds like you have a pressure differential issue. Have your dealership compare what the BCM is reading on the high and low side pressure sensors while the tech is actually checking the pressure. I had a problem where my A/C wouldn't start and I had a bad low side pressure sensor.
 

· Premium Member
Joined
·
24,131 Posts
Low refrigerant (it's not Freon anymore) can also cause the symptoms you described. The fact that they put dye in it is good.
 

· Premium Member
Joined
·
24,131 Posts
The fact that its doing the hot/cold business again means it's probably low again. The leak dye should help pinpoint the problem now.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top